Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

we have got new Lenovo T400 laptops in company with company's reinstalled WindowsXP OS.

Nobody is successful to boot this Windows as RAW system in vmware/vmplayer (loading from physical partition).

I have sda1(XP), sda2(data), sda3(linux), sda4(swap) and grub is installed on sda3 and have generic code in MBR to be started at first place to load linux and XP (chainloader +1). All this works perfectly outside of vmware, but once I try to boot XP fro vmware in Linux, then grub works, but if I select Windows, it become frozen. It works this way on Dell D620. I tried just to fixMBR to have only NTLM loader of XP, but it is just same - it freezes.

Do you know some security/law limitation of Lenovo laptops which could do this?

I tried different configuration as you can see below, but no luck. Grub works, NTLM not. I do MBR.bin by: dd if=/dev/sda of=MBR.bin bs=512 count 1
or
dd if=/dev/sda of=MBR.bin bs=512 count 63
or
dd if=/dev/sda of=MBR.bin bs=63 count 1
Depends on 512 block I justify total disk length.
But it doesn't matter, I used vmware to configure it as well, but still the same grub or, ntlm not.

  1. Disk DescriptorFile

version=1
encoding="UTF-8"
CID=fffffffe
parentCID=ffffffff
isNativeSnapshot="no"
createType="fullDevice"

  1. Extent description

    #RW 1 FLAT "MBR.bin" 0
    ##RW 312581808 FLAT "/dev/sda" 0
    ##RW 312581745 FLAT "/dev/sda" 63
    ##RW 195366464 FLAT "/dev/sda" 1
    #RW 312581807 FLAT "/dev/sda" 1

    RW 1 FLAT "MBR.bin" 0
    RW 312576704 FLAT "/dev/sda" 1

    #RW 446 FLAT "MBR446.bin" 0
    #RW 312576259 FLAT "/dev/sda" 446

  2. The Disk Data Base

    #DDB

ddb.virtualHWVersion = "7"
ddb.longContentID = "96de86b3a450c005fac2b88cfffffffe"
ddb.uuid = "60 00 C2 9e 11 6e 60 ea-b5 3b 53 ab 37 52 66 1f"
ddb.geometry.cylinders = "19457"
ddb.geometry.heads = "255"
ddb.geometry.sectors = "63"
ddb.geometry.biosCylinders = "19457"
ddb.geometry.biosHeads = "255"
ddb.geometry.biosSectors = "63" #ddb.adapterType = "buslogic"
ddb.adapterType = "ide"

Thank you

share|improve this question
add comment

1 Answer

up vote 2 down vote accepted

I'm going to suggest that there's nothing wrong with the virtualization, nor the laptop. Windows is famous for throwing epic wobblies when the hardware changes. You can generally add memory and hard drives, but if you change the CPUid, or the hardware checksum, usually by moving the hard disk to a different computer, then you may never be able to boot the OS again without reinstalling.

http://support.microsoft.com/kb/249694 has some related information, although applies more to Server 2008.

I suspect that the bootloader is loading the wrong HAL modules, and is then crashing.

share|improve this answer
    
Here's an article about making an image that will work for any HAL. myitforum.com/articles/15/view.asp?id=8997 Note that this is specifically not supported by Microsoft. –  duffbeer703 Jan 25 '10 at 13:09
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.