Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have two Panasonic Toughbook CF-30 machines setup from the same installer CD. Both machines were joined to the domain and moved into the same OU. Both machines have no errors in the event logs on startup. One machine gets the 'AutoLogon' group policy which contains the registry entries to get Vista to autologon, the other machines does NO registry processing from any policy that has registry settings.

The working machine logs Event ID 4016 from GroupPolicy which says 'Starting Group Policy Registry Extension Processing. List of applicable policy objects: (No changes detected.) AutoLogon Policy'

The other machine does not have any events which mention registry processing.

Any pointers on where to dig / what to try next?

share|improve this question
    
As a wild guess, have you compared the UAC settings on both machines? –  joeqwerty Jan 27 '10 at 1:17
    
I will double-check that first thing in the morning. –  Aaron C. de Bruyn Jan 27 '10 at 3:56
    
Sorry for the delay. I tested both machines with UAC enabled, and both with it disabled. Same result. –  Aaron C. de Bruyn Feb 1 '10 at 18:02

2 Answers 2

up vote 1 down vote accepted

Stumbled across this article: http://blog.mpecsinc.ca/2009/05/vista-service-pack-2-not-applying-group.html

Installed KB943729 and now the registry settings are being applied. Software Update Services says this update is 'installed/not applicable' to the Vista machines, but manually installing it fixes the problem.

share|improve this answer

I would start by running gpresult on the Vista machine with the issue. It will tell you what policys are applied with a lot of other useful troubleshooting information. Also, have you tried gpupdate /force? Do you have multiple DCs? If you do, then it might be contacting another DC that might not have received the GP changes.

share|improve this answer
    
Thanks for replying Xeon. Sorry, I should have added that info to the initial question. Gpresult and the GPMC both show the policy being applied with no errors, and that they are contacting the Windows 2008 DC which is where I made the changes. I have tried gpupdate /force and rebooting many times during the testing. I have also made sure the toughbooks are plugged in to the LAN instead of attempting this wirelessly. –  Aaron C. de Bruyn Jan 27 '10 at 3:52

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.