Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I run services.msc then checked DHCP is already started, but:

C:\Documents and Settings\Administrator>ipconfig /all

Windows IP Configuration

   Host Name . . . . . . . . . . . . : ROLIFE
   Primary Dns Suffix  . . . . . . . :
   Node Type . . . . . . . . . . . . : Unknown
   IP Routing Enabled. . . . . . . . : No
   WINS Proxy Enabled. . . . . . . . : No


   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Realtek RTL8102/8103/8136 Family PCI-E FE
 NIC
   Physical Address. . . . . . . . . : XX-XX-XX-XX-XX-57
   DHCP Enabled. . . . . . . . . . . : No
   IP Address. . . . . . . . . . . . : xxx.xxx.xxx.65
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . : xxx.xxx.xxx.254
   DNS Servers . . . . . . . . . . . : xxx.xxx.xxx.5
                                       xxx.xxx.xxx.133
   NetBIOS over Tcpip. . . . . . . . : Disabled

C:\Documents and Settings\Administrator>ping localhost

Pinging ROLIFE [127.0.0.1] with 32 bytes of data:

Reply from 127.0.0.1: bytes=32 time<1ms TTL=128
Reply from 127.0.0.1: bytes=32 time<1ms TTL=128
Reply from 127.0.0.1: bytes=32 time<1ms TTL=128
Reply from 127.0.0.1: bytes=32 time<1ms TTL=128

Ping statistics for 127.0.0.1:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 0ms, Maximum = 0ms, Average = 0ms

How can I enable it?

share|improve this question
add comment

2 Answers

up vote 2 down vote accepted

Your interface is set up with a static IP address, therefore DHCP on that interface is disabled. In order to enable it go to your Network Connections page through your Control Panel, right click on the interface in question and select Internet Protocol (TCP/IP). Click properties and select Obtain an IP Address Automatically. Hit OK a few times and your computer will start looking for a DHCP server to pick up and automated address.

Also, you really shouldn't post public IP addresses like that on the web. Every one on the site now knows the operating system you are running and the IP it is running on, you've given us all the first two things we need to try to breach your system.

share|improve this answer
add comment

You have set up the DHCP server on the machine, but not the DHCP client. So your server can give DHCP addresses, but it isn't asking for an address. In most cases you wouldn't want your DHCP server to also be a client.

Unless you know what you are doing, you probably don't want two DHCP servers on your network, so think about what you are trying to achieve here:

  • Make the server supply IP configuration to other computers on the network, and there is no other DHCP server on the network (e.g. a router with DHCP on) - if its that you have done the right thing
  • Automatically configure the IP settings on this server - in which case, turn off the DHCP service, and enable DHCP in TCP/IP settings.
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.