Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

i'm having big trouble with my proftpd installation: the login is slow as hell, it takes about 10 seconds and more and that's to much for the default settings of most ftp clients. i'm using mysql and mod_sql as backend for the login.

i've already searched a bit and added the following to my proftpd configuration:

UseReverseDNS off
IdentLookups off
ServerIdent on “...”

but that did not help at all. mysql is already set to not make any DNS lookups.

at the moment i have no idea, what to try next -- do you have any?

thanks a lot!

harald

share|improve this question
    
Maybe there is some invalid DNS entries in your interfaces config files? –  Maxwell Jan 27 '10 at 9:15
    
thanks for your suggestion -- no ... the DNS entries are correct. i also thought, that proftpd should avoid any DNS lookups when specifying the above configuration options? –  harald Jan 29 '10 at 10:19

1 Answer 1

up vote 0 down vote accepted

here's the answer for my problem:

apparently the SQLAuthenticate directive was the problem. it was set to:

SQLAuthenticate users userset

i've changed this to

SQLAuthenticate users

now authentication is fast as hell.

i've found a howto on the proftpd site, that explains why this configuration may cause problems:

http://www.proftpd.org/docs/howto/SQL.html

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.