Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I am using Windows7 and XAMPP 1.7.3(it's 32bit but says it works on 64). When I click on start Apache nothing happens but beneath it is written:

"Busy.... Apache Service started"

But the green running text does not appear

Port 80 in Skype is disabled. I do not have IIS on my computer.

When I tried to start the Apache 2.2 service from the control panel, it throws an alert box stating it's a service specific error code 1.

Someone said change Listen 80 to 85 in the httpd.conf file. This didn't work. When I tried to start the Apache 2.2 service from the control panel, it throws an alert box stating it's a service specific error code 1.

How can I solve this?

share|improve this question
    
Are there any errors showing up in the event viewer? –  Skaughty Jan 27 '10 at 14:17
    
Thanks for getting back. Error Viewer message below. The Apache2.2 service terminated with service-specific error Incorrect function.. Similar to the alert box 'error code 1' –  user33041 Jan 27 '10 at 14:33
    
and this in error log Syntax error on line 505 of C:/Program Files (x86)/xampp/apache/conf/httpd.conf: SSLSessionCache: Invalid argument: size has to be >= 8192 bytes checking config now ... line 505 <IfModule ssl_module> SSLRandomSeed startup builtin SSLRandomSeed connect builtin SSLSessionCache "shmcb:logs/ssl.scache(512000)" SSLSessionCacheTimeout 300 </IfModule> –  user33041 Jan 27 '10 at 14:41

3 Answers 3

up vote 1 down vote accepted

I had the same problem on Windows 7 64. I did install XAMPP to the 'program files' folder though. I thought I had set the permissions correctly for the xampp foldder afterwards but Apache would not start. To be certain that this was not related to the install being in the 'program files' directory I heeded the advice given above and reinstalled to c:\xampp. That did it. For me XAMPP worked when installed outside of the 'program files' dir.

share|improve this answer
    
Thanks I will try this in the future as this seems to be the solution for XAMPP on Windows 7. I'm sticking with my XP laptop for now. Strange, I can't recall seeing any mention of this on the XAMPP website or installation documents. –  user33041 Feb 24 '10 at 11:47

Try dropping into command line and manually run xampp_stop.exe, and then run xampp_start.exe and see what it tells you. I have had mine act a little quirky in the past and looking at the command output will typically lead me in the right direction.

Windows 7 has acted a little strange for me when I have it installed as a service. I have had to disable service and just start it manually (albeit through the console) each time I boot into my OS.

This should report any Virtual Host problems, log files missing, etc.

share|improve this answer
    
Thanks for the suggestion. No message comes up on screen when using cmd line. It simply appears then disappears for xampp_stop and with xampp_start it just says xampp starting ... then closes –  user33041 Jan 28 '10 at 11:25
    
You might have a bum installation. I would remove your current install, reboot the machine, and reinstall. Also, be sure to install it outside of the 'program files' directory since Vista and 7 put extra permissions on that folder. I usually set mine up in c:\xampp\. Let me know how that goes for you. –  Shane Jan 28 '10 at 14:57
    
Thanks I will try this in the future as this seems to be the solution for XAMPP on Windows 7. I'm sticking with my XP laptop for now. Strange, I can't recall seeing any mention of this on the XAMPP website or installation documents. –  user33041 Feb 24 '10 at 11:46

I finally figured out my problem: (on Win XP)

When I installed wamp, C: was not my root drive - my main drive was E:. Even though I changed the installation path to be E:\wamp I figured that some files in the E:\wamp\bin\apache\Apache2.2.21\conf\extra directory have hard coded paths on C:. Just replace them with the appropriate path on your installation drive. Check the httpd-autoindex, httpd-dav, httpd-multilang-errordoc, httpd-ssl, httpd-vhosts.

Then restart the apache service.

I hope this will help you.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.