Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

When I browse my site with IE8, it gives the error below.

"The security certificate presented by this website was not issued by a trusted certificate authority."

But when I use Firefox, it says it's verified by GoDaddy.com, Inc.

I installed gd-class2-root.cer to IE8 but the problem persists. Do you have any ideas for that?

Thanks!

share|improve this question
    
I've heard that GoDaddy certs have had issues in IE8, but I can't find reference to that right now.... I seem to remember having to get GoDaddy support on the phone, something invalid in the validation path or something like that. –  squillman Jan 27 '10 at 16:30
add comment

4 Answers

Use http://www.sslshopper.com/ssl-checker.html to make sure that the server is giving out all the correct Intermediate certificates. There are usually 3 of them with GoDaddy.

share|improve this answer
    
I checked it and it's valid. –  newth Jan 28 '10 at 15:07
add comment

The directions for GoDaddy certificates indicates that you should disable the "Starfield Class 2 Certificate Authority" certificate. Ran into the same problem recently. Had to enable (now runs with no problem).

Load an MMC console with "Certificates" snap in for the local computer & Computer Account. The go to Intermediate Certification Authorities. From there, go to the Certificates folder. Right click on the "Starfield Class 2 Certificate Authority" cert. You should see the "Disable all purposes for this certificate" selected... choose the top option "Enable all purposes for this certificate".

share|improve this answer
    
I checked but there is no such certificate exists there. I'm using Windows 7, maybe it helps. –  newth Jan 28 '10 at 12:32
add comment
up vote 0 down vote accepted

I downloaded all certificates from Go Daddy Repository and installed gd_bundle.crt, now it it seems ok.

share|improve this answer
add comment

This could help!

After bying a certificate at Go Daddy, i installed it on my apache unix server.

The certificate installation was ok everywhere, firefox, Chrome, IE9, Opera, Iphone, IPad, Android.

Except on IE8 and in the Go Daddy test tools, where a get an error message.

I solved this problem, simply (after hours!) by changing the next parameters in my apache configuration file.

SSLCertificateFile SSLCertificateKeyFile SSLCertificateChainFile

In the default SSL virtual Host section.

I understand that some browser like IE8, QtWeb, when reaching a https web site ask then the certificate whitout the new HTTP host parameter. Then they get the values of the default virtualHost .

Regards Gilbert

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.