Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm using some custom mibs but for some items I get a message like:

$ snmpwalk -c enterprise -v 1 -M mib -m ALL host iso.3.6.1.4.1.5485.2.10.111.1.1
...
MYCOMPANY-MIB::rejectedMessages.11 = Wrong Type (should be Counter32): INTEGER: 0
..

I know there is a mismatch between the mib file and the snmp data, but I want just to supress the warning. Changing the mib isn't an option.

share|improve this question

1 Answer 1

up vote 1 down vote accepted

how about just piping it through grep -vi 'Wrong Type' ?

share|improve this answer
    
I need to suppress the message, not the entire line. –  user9471 Jan 27 '10 at 20:14
1  
filter it through | sed -e 's/Wrong Type (should be .*)://' ? –  Darren Chamberlain Jan 27 '10 at 21:54
    
Ok, I'll accept this workaround =) –  user9471 Jan 28 '10 at 13:31

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.