Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

The SpamAssassin 2010 bug was supposed to be fixed not long after the bug became widely known, and indeed the offending rule in my /usr/share/spamassassin/ has been updated. However, incoming messages are still being tagged by this eg:

X-Spam-Status: No, score=3.188 tagged_above=-999 required=6.31 tests=[BAYES_50=0.001, FH_DATE_PAST_20XX=3.188, SPF_PASS=-0.001]

Here is the relevant rule:

header   FH_DATE_PAST_20XX      Date =~ /20[2-9][0-9]/ [if-unset: 2006]
describe FH_DATE_PAST_20XX      The date is grossly in the future.

I'm on spamassassin/3.2.5-2+lenny1.1~volatile1 on Debian Lenny, completely up to date. Any pointers on where to look to figure out what's going on? I don't know anything about SpamAssassin; someone else usually manages this but I'm free right now and am trying to figure out what the problem is because it's been annoying us for a while and we only just realized this bug was still affecting us.

Update: I've lowered the score for the FH_DATE_PAST20XX rule to 0.1, both in /etc/spamassassin/ and /usr/share/spamassassin/ and it's still giving 3.188 points for this rule. Any idea what's going on? This really has me stumped.

Update 2: It seems that after restarting amavisd, it's been fixed. What's the difference between amavisd and spamd? It seems like both should not be running, or something.

share|improve this question

That rule you posted is the buggy one - take a look for a file such as:


This will supersede the default rule in /usr/share/ (see here) - you want to see the fixed rule have a [2-9] in it instead of [1-9]:

header   FH_DATE_PAST_20XX      Date =~ /20[2-9][0-9]/ [if-unset: 2006]
describe FH_DATE_PAST_20XX      The date is grossly in the future.

After verifying that, make sure you've actually restarted the spamd daemon component of SpamAssassin so it can re-read it's rules.

share|improve this answer
you edited your original post after I posted this seconds ago for the rule to say [2-9] -- all you should need now to do is restart the spamd process and possibly your MTA connected to it. – troyengel Jan 28 '10 at 1:09
Nope, I didn't edit that part of the post, it was always like that. I've restarted spamd maybe 10 times in the past hour. Also, the file in /var/lib/spamassassin/3.002005/updates_spamassassin_org/ also has the fixed rule with [2-9] instead of [1-9]. While I'm not very practiced with regex, I'm not ignorant with it either. What I edited was the fact that I had tried changing the score in /etc/spamassassin/ and even in the main file and it still hasn't had an effect. – Ibrahim Jan 28 '10 at 1:17
I also restarted postfix, still no change. – Ibrahim Jan 28 '10 at 1:18
See for proof that it was always like that. – Ibrahim Jan 28 '10 at 1:19
Sorry what I meant is you edited the original post I was referring to in my original answer so the reference was lost. amvisd is anti-virus, so they could be complimentary in nature - amvisd checks for virii, spamd is spam checking. If you had to restart amvisd then most likely the configuration connects the two together -- possibly amvisd was keeping a static spamd thread open for dedicated (sub)processing, hard to say without knowing your specific server minutiae. Every mail server is put together differently to meet the specific business needs at hand. – troyengel Jan 28 '10 at 23:46
up vote 0 down vote accepted

It turned out I needed to restart amavisd, not spamd.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.