Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I recently upgraded my desktop to Windows 7 and opened it up for ssh from other boxes (using OpenSSH as installed with Cygwin).

Everything works - however, there's a very, very long delay (sometimes up to 30 seconds) when I first attempt to make the connection (before it asks for the password), even from a wired connection. There's no such delay when I ssh remotely to my boxes at work.

I'll be very grateful for your insights on what I can do to debug this. I recognize there are a zillion small things that affect the speed of establishing an ssh connection, but this seems so drastically bad that there must be SOMETHING majorly wrong.

ssh -vvv output follows (warning: long) - one long pause is after it lists the identity files (identity file /Users/Arkaaito/...), and then there's another long pause after it lists the keys (key: /Users/Arkaaito...). I suppose it might be just because I don't have key-based authentication set up yet. (Ironically, I wanted to wait to add that until I had it working with password-based authentication, on the internal network.)

Arkas-MacBook-Pro:~ Arkaaito$ ssh -vvv Alsant@192.168.0.196
OpenSSH_5.2p1, OpenSSL 0.9.8l 5 Nov 2009
debug1: Reading configuration data /etc/ssh_config
debug2: ssh_connect: needpriv 0
debug1: Connecting to 192.168.0.196 [192.168.0.196] port 22.
debug1: Connection established.
debug1: identity file /Users/Arkaaito/.ssh/identity type -1
debug1: identity file /Users/Arkaaito/.ssh/id_rsa type -1
debug1: identity file /Users/Arkaaito/.ssh/id_dsa type -1
debug1: Remote protocol version 2.0, remote software version OpenSSH_5.1
debug1: match: OpenSSH_5.1 pat OpenSSH*
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_5.2
debug2: fd 3 setting O_NONBLOCK
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug2: kex_parse_kexinit: diffie-hellman-group-exchange-sha256,diffie-hellman-group-exchange-sha1,diffie-hellman-group14-sha1,diffie-hellman-group1-sha1
debug2: kex_parse_kexinit: ssh-rsa,ssh-dss
debug2: kex_parse_kexinit: aes128-ctr,aes192-ctr,aes256-ctr,arcfour256,arcfour128,aes128-cbc,3des-cbc,blowfish-cbc,cast128-cbc,aes192-cbc,aes256-cbc,arcfour,rijndael-cbc@lysator.liu.se
debug2: kex_parse_kexinit: aes128-ctr,aes192-ctr,aes256-ctr,arcfour256,arcfour128,aes128-cbc,3des-cbc,blowfish-cbc,cast128-cbc,aes192-cbc,aes256-cbc,arcfour,rijndael-cbc@lysator.liu.se
debug2: kex_parse_kexinit: hmac-md5,hmac-sha1,umac-64@openssh.com,hmac-ripemd160,hmac-ripemd160@openssh.com,hmac-sha1-96,hmac-md5-96
debug2: kex_parse_kexinit: hmac-md5,hmac-sha1,umac-64@openssh.com,hmac-ripemd160,hmac-ripemd160@openssh.com,hmac-sha1-96,hmac-md5-96
debug2: kex_parse_kexinit: none,zlib@openssh.com,zlib
debug2: kex_parse_kexinit: none,zlib@openssh.com,zlib
debug2: kex_parse_kexinit: 
debug2: kex_parse_kexinit: 
debug2: kex_parse_kexinit: first_kex_follows 0 
debug2: kex_parse_kexinit: reserved 0 
debug2: kex_parse_kexinit: diffie-hellman-group-exchange-sha256,diffie-hellman-group-exchange-sha1,diffie-hellman-group14-sha1,diffie-hellman-group1-sha1
debug2: kex_parse_kexinit: ssh-rsa,ssh-dss
debug2: kex_parse_kexinit: aes128-cbc,3des-cbc,blowfish-cbc,cast128-cbc,arcfour128,arcfour256,arcfour,aes192-cbc,aes256-cbc,rijndael-cbc@lysator.liu.se,aes128-ctr,aes192-ctr,aes256-ctr
debug2: kex_parse_kexinit: aes128-cbc,3des-cbc,blowfish-cbc,cast128-cbc,arcfour128,arcfour256,arcfour,aes192-cbc,aes256-cbc,rijndael-cbc@lysator.liu.se,aes128-ctr,aes192-ctr,aes256-ctr
debug2: kex_parse_kexinit: hmac-md5,hmac-sha1,umac-64@openssh.com,hmac-ripemd160,hmac-ripemd160@openssh.com,hmac-sha1-96,hmac-md5-96
debug2: kex_parse_kexinit: hmac-md5,hmac-sha1,umac-64@openssh.com,hmac-ripemd160,hmac-ripemd160@openssh.com,hmac-sha1-96,hmac-md5-96
debug2: kex_parse_kexinit: none,zlib@openssh.com
debug2: kex_parse_kexinit: none,zlib@openssh.com
debug2: kex_parse_kexinit: 
debug2: kex_parse_kexinit: 
debug2: kex_parse_kexinit: first_kex_follows 0 
debug2: kex_parse_kexinit: reserved 0 
debug2: mac_setup: found hmac-md5
debug1: kex: server->client aes128-ctr hmac-md5 none
debug2: mac_setup: found hmac-md5
debug1: kex: client->server aes128-ctr hmac-md5 none
debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
debug2: dh_gen_key: priv key bits set: 127/256
debug2: bits set: 521/1024
debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
debug3: check_host_in_hostfile: filename /Users/Arkaaito/.ssh/known_hosts
debug3: check_host_in_hostfile: match line 16
debug1: Host '192.168.0.196' is known and matches the RSA host key.
debug1: Found key in /Users/Arkaaito/.ssh/known_hosts:16
debug2: bits set: 522/1024
debug1: ssh_rsa_verify: signature correct
debug2: kex_derive_keys
debug2: set_newkeys: mode 1
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug2: set_newkeys: mode 0
debug1: SSH2_MSG_NEWKEYS received
debug1: SSH2_MSG_SERVICE_REQUEST sent
debug2: service_accept: ssh-userauth
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug2: key: /Users/Arkaaito/.ssh/identity (0x0)
debug2: key: /Users/Arkaaito/.ssh/id_rsa (0x0)
debug2: key: /Users/Arkaaito/.ssh/id_dsa (0x0)
debug1: Authentications that can continue: publickey,password,keyboard-interactive
debug3: start over, passed a different list publickey,password,keyboard-interactive
debug3: preferred publickey,keyboard-interactive,password
debug3: authmethod_lookup publickey
debug3: remaining preferred: keyboard-interactive,password
debug3: authmethod_is_enabled publickey
debug1: Next authentication method: publickey
debug1: Trying private key: /Users/Arkaaito/.ssh/identity
debug3: no such identity: /Users/Arkaaito/.ssh/identity
debug1: Trying private key: /Users/Arkaaito/.ssh/id_rsa
debug3: no such identity: /Users/Arkaaito/.ssh/id_rsa
debug1: Trying private key: /Users/Arkaaito/.ssh/id_dsa
debug3: no such identity: /Users/Arkaaito/.ssh/id_dsa
debug2: we did not send a packet, disable method
debug3: authmethod_lookup keyboard-interactive
debug3: remaining preferred: password
debug3: authmethod_is_enabled keyboard-interactive
debug1: Next authentication method: keyboard-interactive
debug2: userauth_kbdint
debug2: we sent a keyboard-interactive packet, wait for reply
debug1: Authentications that can continue: publickey,password,keyboard-interactive
debug3: userauth_kbdint: disable: no info_req_seen
debug2: we did not send a packet, disable method
debug3: authmethod_lookup password
debug3: remaining preferred: 
debug3: authmethod_is_enabled password
debug1: Next authentication method: password
Alsant@192.168.0.196's password: 
share|improve this question
1  
Can you run your ssh command with -vvv in it and paste the output this usually points right at the issue. –  ScottZ Jan 28 '10 at 3:48
    
@ScottZ - Excellent tip; I ran the command with -vvv and have pasted the output, though I have to confess I couldn't find anything that seemed obviously wrong. –  Arkaaito Oct 13 '10 at 9:36
    
The key is to look at this -vvv output while it is in progress and figure out the point where the long delay occurs. And yes, in most cases (but not all) it is reverse-DNS related: reverse DNS of the remote ends in a timeout which takes several seconds. –  arielf Mar 2 '13 at 18:20
add comment

3 Answers

I'd be willing to bet that it's a lack of reverse DNS. Try disabling reverse DNS lookup in the server and see if that helps.

share|improve this answer
    
+1 - the number of times I've been bitten by this... –  Murali Suriar Jan 28 '10 at 12:12
add comment

Take a look at ssh_config and look for GSSAPIAuthentication. Make sure that value is set to 'no'. In Ubuntu on the new packages of openssh, this comes enabled by default and I've experienced delays up to 10 seconds connecting to SSH hosts until I've disabled the option.

share|improve this answer
add comment

I don't know if this is the reason, but perhaps it's Autotuning? You can temporarily disable it to test.

http://www.kombitz.com/2009/01/09/windows-7-auto-tuning/

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.