Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to run aspnet_regiis.exe in order to perform a couple of tasks on my development machine (running IIS 6 on Windows Server 2003 and a member of an Active Directory domain). So I change to the folder C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727, and run:

aspnet_regiis –i

But all that happens is that it displays the command line options for the utility, and doesn't actually execute or do anything. This doesn't work either:

aspnet_regiis –ga MYDOMAIN\user

In fact, any switch I try has the same effect - no actual action, just the display of the options.

Can anyone tell me why this might be?

share|improve this question
up vote 2 down vote accepted

First, check the start of the options listing, there might be an error there, here (Win7) with .NET 2's aspnet_regiis in an elevated PowerShell prompt I get:

Note: This utility has limited capabilities on the Windows Vista operating system. It is recommended that you use the "Turn on or off Windows features" option of the "Programs" component of Control Panel to install or remove ASP.NET. It is also recommended that you use the IIS Manager component or the Appcmd.exe tool to configure ASP.NET applications.

And then a listing of the options.

Second try:

aspnet_regiis -lk

to just list the mappings that exist this might:

  • fail like above: so use IIS manager to install/configure on IIS7 or 7.5.
  • list nothing, or give an error: ensure ASP.NET is installed (newer OS's do not enable it by default)
  • something else...
share|improve this answer
Sorry, I forgot to say: I'm running IIS 6 on Server 2003 (I've updated the question now). Anyway, now I'm totally confused—I did as you said, and it listed the mappings, no problem. So I tried running aspnet_regiis –i again, and now it works, as does granting permissions with –ga! I haven't changed the machine's configuration at all. Utterly puzzling. – Mark Bell Jan 28 '10 at 13:54
@MarkB: Fixed :-), not knowing why :-(. Unless you get a repeat, I would just move on. – Richard Jan 29 '10 at 9:24
Well +1 and thanks anyway! – Mark Bell Jan 29 '10 at 9:49

In my experience on 2008R2, you have to cd to the directory it lives in


then run the command with options from there. Otherwise, it will do nothing but spit out options.

    aspnet_regiis –i
share|improve this answer

I've been bashing my ahead against this wall for a few hours myself, and then it finally came to me:

You may be in the wrong /Framework/ directory. I was in /Framework64/ and having these exact issues, but once I switched to /Framework/, aspnet_regiis -iru ran perfectly.

share|improve this answer

Instead of –i try to use /i.

Example: aspnet_regiis /i

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.