Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Have a couple of workstations with shared folders that I'd like to backup. Backup Exec 12.5 sees them in the selection list, but failed saying that the Remote Agent couldn't be contacted:

V-79-57344-3844 - The media server was unable to connect to the Remote Agent on machine machine-1.foo.local.
The media server will use the local agent to try to complete the operation.
Unable to attach to \\machine-1.foo.local\SharedFolder.
V-79-57344-33899 - The resource could not be backed up because an error occurred while connecting to the Backup Exec for Windows Servers Remote Agent. 

Do I need to deploy agents for this?

share|improve this question
    
This is my favored method for backing up domain controllers - I'd much prefer to snap up a single ntbackup systemstate file than a bunch of redundant windows system files... –  Kara Marfia Jan 28 '10 at 16:47
add comment

4 Answers

up vote 2 down vote accepted

I haven't tried this on a workstation, but you do NOT need the agent installed to backup files on a shared folder on a server OS. You will, however, continue to receive that error in the backup summary. (I'll be thrilled if somebody posts a way to suppress that message)

Tools -> Options -> Network and Security -> "Enable selection of user shares"

At this point, you'll have a "User Defined Selections" area in your job under Selections. It's important to select the share from this spot, since if you try to select the share under "Windows Systems" it'll look for the agent.

If you right-click User Defined Selections, you'll have an option to Manage UD Selections, wherein you can add in hosts that you'd like to appear in the list. Just the names are fine, it'll discover the shares on its own.

share|improve this answer
    
You posted the same answer while I was typing my response! Have an upvote... –  hmallett Jan 28 '10 at 16:07
    
Think we're heading in the right direction, although under "User Defined Selections", there's nothing to check off besides the top-level "User Defined" item; when I try to expand the tree, the + sign disappears. Under the Windows Systems, the workstations' shares are still checked, however. Do I need to remove those selections first? –  gravyface Jan 28 '10 at 16:36
    
Well, you'll always get an error for the backups it tries in the Windows Systems item on machines without an agent, so you probably want to remove those (though it won't keep the user-defined job from running). I'll edit above with the step I skipped. –  Kara Marfia Jan 28 '10 at 16:44
add comment

Yep, you need to install the Backup Exec Remote Agent on the Workstations you want to back up.

share|improve this answer
add comment

As Sam stated, you do need an agent. However, there are ways around this. You could use scheduled tasks (not super reliable) to move the backup folder to a server/workstation that you do have a backup agent already running on.

share|improve this answer
add comment

You are supposed to need an agent for this with Backup Exec 12.5, however...

Try creating your backup selection list, and right-click User defined selections. Select Manage User-defined Selections and add the share. You'll get a warning, but the backup will still work.

Note that I've tried this on a 12.5 system that was upgraded from Backup Exec 10d.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.