Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am using ubuntu 9.10 and following the next tutorial: http://www.howtoforge.com/perfect-server-ubuntu-9.10-ispconfig-3-p4. I am at point 15. This says i must install quota etc. This have i done.

Now i must add usrjquota=aquota.user,grpjquota=aquota.group,jqfmt=vfsv0 to my /etc/fstab file. When i did this i had te next code:

/dev/xvda2      /             ext3     defaults,errors=remount-ro,usrjquota=aquota.user,grpjquota=aquota.group,jqfmt=vfsv0 0 0
/dev/xvda1      none          swap     defaults                   0 0
proc            /proc         proc     defaults                   0 0
devpts          /dev/pts      devpts   gid=5,mode=620             0 0

I have run the commands touch /aquota.user /aquota.group and chmod 600 /aquota.

Now i must run the command mount -o remount / but when i do it i get the following error:

mount: / not mounted already, or bad option

When i delete the usrjquota=aquota.user,grpjquota=aquota.group,jqfmt=vfsv0 it works fine. But this line must stand there. What is going wrong???

Tom

share|improve this question
add comment

1 Answer

up vote 3 down vote accepted

I would try removing the word "defaults" from that options list. You don't want the default options, you want all the stuff you provided. Remove that, and see if it will remount properly.

So that first line should look like this:

/dev/xvda2      /             ext3     errors=remount-ro,usrjquota=aquota.user,grpjquota=aquota.group,jqfmt=vfsv0 0 0
share|improve this answer
    
thank you! it's works!! –  Timo Jan 28 '10 at 17:50
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.