Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have recently taken over for another system admin on a project and am in the process of figuring out what we have on our servers before rebuilding things the way they need to be. I have one Dell server running Fedora Core 8. I am unable to connect to the network at all.

I am plugged into a known good port, I have tried dhcp and manual set IP configurations. The dhcp will not receive a lease. After both methods I am not even able to ping my gateway. I have diabled all the firewalls to make sure those are not the issue. Here is my ifconfig.

eth0   Link encap:Ethernet HWaddr 00:1C:23:E2:FC:56
       UP BROADCAST MULTICAST MYU:1500 Metric:1
       RX packets:0 errors:0 dropped:0 overruns:0 frame:0
       TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
       collisions:0 txqueuelen:1000
       RX bytes:0 (0.0b) TX bytes:0 (0.0b)
       Interrupt:16

This is configured with dhcp just after doing a dhclient eth0 and it returns no working leases.

What else should I check?

share|improve this question
    
sorry to ask but have you tried rebooting the server? I've gone through a similar issue were I would assign a static but the dhcp lease would end up coming back. –  Patrick R Jan 28 '10 at 20:11
    
I tried that also –  trobrock Jan 28 '10 at 20:14
    
Does it have a link on eth0? What does ethtool eth0 say? –  James Jan 28 '10 at 20:43

1 Answer 1

up vote 0 down vote accepted

Well I'd run an:

ifconfig -a
route -v

Check dmesg and logs for related info. Check the ethernet card itself. Is the other Sysadmin available? Did he leave under less than amicable circumstances?

You mention firewalls was the server running iptables?

share|improve this answer
    
The firewall was running iptables, and the last sysadmin was not so much a sysadmin, as one of the windows servers he ran had a virus. I will get to the servers today and post the output of the commands you guys told me to run. –  trobrock Jan 29 '10 at 14:19
    
Thanks everyone, after examining dmesg after trying to bring each interface up I realize that what was believed to be eth0 was eth1, so now things are running on eth1 –  trobrock Jan 29 '10 at 16:53

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.