Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have a problem with dns when connected to my work vpn. For ease of explanation I'll use the following in my outline of the problem: - name of my machine on work network is REMOTE_XP (original i know) - ip of my machine on work network is 192.168.2.80 - name of my machine on my local network is LOCAL_XP - ip of my machine on my local network is 10.0.0.3

What I want to be able to do when connected to vpn: - browse the internet from LOCAL_XP - ping by name REMOTE_XP

Now it seems I've so far mentioned either 1 but not both of my wishlist.

If i go to my vpn network properties (on LOCAL_XP) and uncheck the "use default dns on remote network" then I can browse the internet from my local machine but can't ping REMOTE_XP (though I can ping 192.168.2.80)

If I check "use default dns..." then I can ping REMOTE_XP but can't browse the internet from LOCAL_XP.

Is there a way I can have my dns cake and eat it, or will I have to accept that it will be an either/or situation?

Thanks in advance.

share|improve this question
1  
if the only host you want to ping is REMOTE_XP, then add it to your host file! –  Nick Kavadias Jan 29 '10 at 11:01
    
true, but yes I should have explained, I kept it brief for the question. It is unfortunately not the only host I want to reach by name. Thanks anyway. –  David Archer Jan 29 '10 at 11:46
    
How do you figure your machine name will be different on the two networks, or are you referring to the FQDN? Are you using DHCP on both networks and are you passing all the appropriate settings via DHCP or do you have some static entries? –  John Gardeniers Jan 29 '10 at 13:11
    
@john, its not that my machine name will be different. LOCAL_XP is my home box, and REMOTE_XP is my work box –  David Archer Jan 29 '10 at 18:15
    
Sorry, I though you were talking about one machine. –  John Gardeniers Jan 29 '10 at 20:36

2 Answers 2

Did you uncheck the "Use default gateway on remote network" ?

You can see that feature in your VPN IP properties, then advanced and then, general tab.

Let me know...

D.

share|improve this answer
    
Hi thanks yes I tried this and that is where i ended up with my current either/or situation –  David Archer Jan 29 '10 at 18:15

The problem sounds like a DNS issue, since you can ping the REMOTE_XP by IP address and view web pages when you change your DNS back to your home router (or DNS server).

Most likely the DNS server you get when you connect to the VPN does not do recursive DNS for your LOCAL network (10.0.0.0/24). Turn on recursive DNS for that network on your remote work DNS server. Sorry I can't tell you how to do that; I don't do windows.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.