Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I set up php/fastcgi with nginx and now I want to upload very large files via a java-applet. After about 30 seconds, the applet reports a "Broken pipe". In the server logs, i find nothing. I changed any setting in the php.ini (max_execution_time, max_input_time, memory_limit, post_max_size) to very high values, but nothing helps.

Any idea?

share|improve this question

2 Answers 2

How big is your upload? Did you check the free space on the client_body_temp_path (http://wiki.nginx.org/NginxHttpCoreModule#client_body_temp_path) Or the other nginx client_body* items?

share|improve this answer
    
the upload is splitted into post requests of about 10mb/chunk. # df -h Filesystem Size Used Avail Use% Mounted on /dev/sda1 9.9G 1.4G 8.0G 15% / /dev/sda2 147G 2.1G 138G 2% /mnt And yes, all client_body-settings are set large enough. –  schneck Jan 29 '10 at 13:09

Also, have a look at the permissions of the client_body_temp directory as they have to be permissive enough for the user running nginx.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.