Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Please pardon the newbie question, but I can't seem to figure this out.

I followed Voxilla's tutorial to the tee.

But in making calls, my softphones connect, yet no audio (in either direction).

I know from poking around the forums that this is generally caused by two factors: NAT and audio codecs.

I (being new to the arena), however, don't know which. I believe I have Asterisk and the clients restricted to just ulaw, and I also believe I have the correct ports open, and my externip set correctly (I think the Voxilla AMI does this automatically, since it's in the cloud).

I'm a bit lost. I'd be happy to post whatever configuration files that might help, provided you tell me where they are on the filesystem. But like I said before, this is effectively a vanilla install of Voxilla's own FreePBX AMI.

I'd appreciate any help or guidance here. Thanks!

share|improve this question
    
As well as NAT and codec issues, it can also be caused by SIP ALG if you have it enabled on your router or similar device –  jwbensley Nov 10 '12 at 23:16
add comment

2 Answers 2

This sounds like one of either:

  • Firewall problem
  • Nat problem

Either way, your RTP isn't getting through. I would suggest:

  1. Trying it from a different location, where you are not behind a NAT router. If you have a separate router & broadband modem, plug your computer straight into the broadband (and reset it) and try that. If they are integrated, try setting the DMZ on the router to be you computer's local IP. You can also try port forwarding the RTP ports.

  2. Double check your AWS security groups. If you haven't done it right it just won't work.

I've done this with Voxilla's FreePBX AMI and it worked perfectly (excluding CDR, which did not work).

share|improve this answer
add comment

Check did you say asterisk what is your local network. These option is under : /Tools/Asterisk SIP Settings/NAT Settings

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.