Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

When I'm trying to connect to my iis with localhost, everything works fine. When I'm trying to connect with the name of my computer instead of localhost, it doesn't work.

I've found that turning off windows firewall resolves the problem, but I would like to turn on Windows Firewall. So, which program or port should be allowed through the Windows Firewall to make it work?

share|improve this question

migrated from stackoverflow.com Jan 29 '10 at 16:04

This question came from our site for professional and enthusiast programmers.

    
check your firewall logs –  Pentium10 Jan 29 '10 at 9:46
add comment

4 Answers

up vote 7 down vote accepted

If you ping to the name of your computer which ip address do you see in the results? Is that the ip address of your network connection? If that is the case, then you probably have to open up port 80 on your windows firewall. (I assume the site(s) on your IIS are running on port 80.) The firewall has to allow incoming traffic on port 80.

share|improve this answer
add comment

Windows Firewall can not get out to your DNS to resolve your computer name back to 127.0.0.1

You can also put the computer name in the c:\windows\system32\drivers\etc\host file along with the 127.0.0.1 address.

share|improve this answer
    
I've just installed Windows7. In Vista I never had to edit the host file, so there must be another way. –  Lieven Cardoen Jan 29 '10 at 9:51
    
Windows7 has incomming and outgoing firewall, so you outgoing request might be blocked. –  Ian Quigley Jan 29 '10 at 10:01
add comment
  1. open notepad
  2. copy this below line:

    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\NetBT\Parameters]
    
    "NodeType"=-
    "DhcpNodeType"=-
    
  3. save as "NETFIX.REG"

  4. paste to your desktop.
  5. double click.
  6. restart.
share|improve this answer
add comment

Very old post, I know. But for the sake of history and knowledge; Chances are you are using a proxy, in this case you need to add exception for your computer name in the your browser.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.