Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've got a user with an 8130 attached to our Blackberry Enterprise Server who had around 1500 contacts synced to his phone. Now it's only showing 8. I've disabled wireless sync on the phone and in Blackberry Manager, then re-enabled both - the user saw many contacts being added to the phone's address book. Then he let it sit for 20 minutes to let it sync. He unlocked the phone and checked -- same 8 contacts.

I've checked "Filters" on the phone and all categories are unchecked. I've also looked over those 8 contacts in Outlook and can't find anything related (they share a category with hundreds of other contacts, they don't have anything unique about their name, etc). This seems phone-related, and shouldn't be affected by our BES, since he sees contacts being added when the sync restarts.

Any ideas? Does Blackberry have another "Filter" method besides the filter by categories that I'm missing, or is there possible corruption (no errors reported in event viewer on the BES server)? Any suggestions that lead towards a solution are appreciated :)

share|improve this question
Additional info: client says he added a new contact in SugarCRM (which syncs with outlook via a SugarCRM Outlook add-in), and the new contact is showing up on his phone, but another has been removed, so it's still only showing 8 contacts (7 of the originals and this new one). I'm trying MikeyB's suggestion when I can coordinate with the customer in the next couple of days, and it sounds like a good course of action if something is corrupt on the phone and maybe limiting address-book storage to 8 contacts for some reason. – elint Feb 1 '10 at 3:36
That sounds like a very odd failure mode. I'd take a close look at the sync logs in BES. – MikeyB Feb 1 '10 at 13:48
up vote 1 down vote accepted

Try deleting the Address Book service book on the device, clear the Address Book database, then push the Service Books from BES.

share|improve this answer
sounds like a plan. added new info to my main question, but I'll try this Monday or Tuesday, when I can get with the client. – elint Feb 1 '10 at 3:34
Marking you as the solution, as you pointed me in the right direction. The BES sync logs looked fine. I deleted the address book on the device and tried to clear the address book database -- it says it cleared, but 2 contacts remained (of the 8 I was seeing). I couldn't edit/delete them from the device or desktop manager. I ended up backing up everything EXCEPT contacts, wiping handheld, restoring that backup, and re-activating. Full address book synced successfully. Sounds like there were 2 corrupt contacts, or a corrupt address book on the phone. Thanks for the help. – elint Feb 2 '10 at 21:50
Glad to hear it worked! For future reference, there's a neat little shortcut. On the device, go to Address Book | Options. Type: RSET. This will prompt you to delete the address book and reload it from the server. – MikeyB Feb 2 '10 at 22:22

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.