Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

using Fast CGI I can't get it to read the php.ini file. See my phpinfo below.

System Windows NT WIN-PAFTBLXQWYW 6.0 build 6001
Build Date Mar 5 2009 19:43:24
Configure Command cscript /nologo configure.js "--enable-snapshot-build" "--enable-debug-pack" "--with-snapshot-template=d:\php-sdk\snap_5_2\vc6\x86\template" "--with-php-build=d:\php-sdk\snap_5_2\vc6\x86\php_build" "--disable-zts" "--disable-isapi" "--disable-nsapi" "--with-pdo-oci=D:\php-sdk\oracle\instantclient10\sdk,shared" "--with-oci8=D:\php-sdk\oracle\instantclient10\sdk,shared" "--enable-htscanner=shared"
Server API CGI/FastCGI
Virtual Directory Support disabled
Configuration File (php.ini) Path C:\Windows
Loaded Configuration File (none)
Scan this dir for additional .ini files (none)

My php.ini file is residing in both my c:\php and my c:\windows I've made sure it has read permissions in both places from network service.

I've added various registry settings, Environment Variables and followed multiple tutorials found on the web and no dice as of yet. Rebooted after each.

My original install was using MS "Web Platform Installer" however I have since rebooted.

Any ideas on where to go from here would be most welcome.

share|improve this question
add comment

3 Answers

Create a file info.php with

<?php
  phpinfo();
 ?>

Save it to the web published directory.

And use a browser to see output of the file, see the value of

Configuration File (php.ini) Path

share|improve this answer
    
I pulled the above from my phpinfo page. I have that woring. –  Martin Murphy Jun 2 '09 at 17:56
add comment

To make 64-bit IIS load 32-bit DLLs, like the ones PHP uses you need to run this script.

cscript %SYSTEMDRIVE%\inetpub\adminscripts\adsutil.vbs SET W3SVC/AppPools/Enable32bitAppOnWin64 1

share|improve this answer
add comment

Ultimately I found that it was a dummy mistake. I couldn't see the extension because Server 2008 has known extensions disabled by default on a server operating system.

so php.ini.ini was appearing in the file explorer as php.ini

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.