Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I enabled gzip in apache2 and started load testing -- I am seeing a lot of keep alives state busy state -- 95% of the web server worker threads are being used at any given time

While CPU is ok, I am assuming the issue is that the compression is making the threads wait longer --

What could be the issue -- where am I going wrong?

share|improve this question

migrated from stackoverflow.com Feb 2 '10 at 1:22

This question came from our site for professional and enthusiast programmers.

2 Answers 2

What do you compress ? Everything except images ? Size of content ?

Did you do a test load before activating compression ?

share|improve this answer

You will need to check your KeepAlive timeout settings, also from the shell run:

http -l (assuming you are using httpd on RHEL or a derivative distro, not sure about the apachectl equivalent).

You'll see prefork.c or worker.c from there modify you httpd.conf IFModule section, dependent on whether you are running prefok / worker, you can raise the number of apache threads there.

On a cautionary note you should only allow for a number of threads you can comfortably fit in memory, this will vary depending on what modules you have loaded in, you can see a write up here I suggest reading all 3 parts.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.