Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We are setting up an installation of Foswiki (http://foswiki.org/).

A question to other Foswiki/TWiki users here: is there a way to disable e-mail auto-links in a selected page?

I have figured out that by using <noautolink> I can disable automatic wikilinks. It doesn't, however, work for mailto autolinks. So is there a corresponding command for disabling them or does anyone of you know some other workaround?

To be more specific, the problem is that I only need to disable e-mail autolinks, but not other wiki markup conversion. Here is a specific markup example:

 * WikiPageName - contact.author@example.com
 * WikiPageName2 - contact.author2@example.com
 * WikiPageName3 - contact.author2@example.com

If I put the whole markup, let's say inside verbatim block, it disables not only e-mail autolinks, but also all other wiki markup, like automatic wikipage linking and listing style.

Use of a plugin to solve this problem can be considered as well, but a pluginless solution is preferred.

Thanks!

share|improve this question
    
Try scoping <literal/> or <verbatim/> to only appear around addresses. Maybe look for an import plugin that matches your workflow. –  Tobu Feb 10 '10 at 12:19

4 Answers 4

up vote 1 down vote accepted

I'm sorry for not noticing this earlier.

there is a setting in http://foswiki.org/System/DefaultPreferences called NOAUTOLINK that you can set to turn off autolinking.

wrt just Email - yup, harder - monkey patching the core Foswiki::Render::_mailLink might be the most practical.

Sven.

share|improve this answer
    
Thanks for pointing out the method I need to change in order to do what I want to do. I wish there was an easier way. However, since this is the way I suppose I'm gonna have to fix it, I'm marking this as the preferred answer. thanks! –  Jaakko Jun 20 '11 at 20:44

Does <verbatim /> do what you want?

share|improve this answer
    
No, it doesn't :( With verbatim all Foswiki rendering seems to disappear. What I need is to disable only e-mail autolinks. Thank you anyway! –  Jaakko Feb 4 '10 at 15:12

Try < literal> at the beginning of the link and close it with < / literal>

For instance: < literal> abc@spamalot.com < / literal>

This can be used in tables as well as in the main body.

share|improve this answer
    
You are absolutely right: literal works, but it doesn't not solve my problem. Please see my re-edited question for details! –  Jaakko Feb 10 '10 at 12:00

You can use !, <nop> or %NOP%, as shown here

-- Edit for clarification:

Ok, I wasn't clear enough. No, there is no easy solution apart from putting it there, or having a plugin put it there for you (and I don't know of any existing ones doing so). The mailto replacement is done directly inside the rendering engine, so afaict, the only things preventing a mailto are the ones shown on my test page above (which I can't link because serverfault still thinks I'm a spammer, so I'm only allowed 1 link. It's just one link, but...)

The point was... why would you need that? If you write the text, then put the %NOP%. If it comes from a formatted SEARCH, put %NOP% before the formfield. Your example seems to be the result of a SEARCH, so this is easy to fix. Show me your use-case, and maybe I could figure something else out.

share|improve this answer
1  
I know ! or %NOP% can be used to disable individual autolinks, but that is not what I'm looking here. Please re-read the question! –  Jaakko Oct 13 '10 at 7:21

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.