Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

We have a service that runs on a Windows 2008 server under the identity of the builtin Network Service user.

The service needs to communicate with the Internet.

In our network we need to set the Proxy Server in the LAN Settings of IE, for this to work.

No problem doing it for the logged in user, but how do I do it for the Network Service user?

share|improve this question
    
Does your proxy ask for authentication ? if so, you need to set exception, so your proxy won't ask for an account from this server ip –  Mathieu Chateau Feb 3 '10 at 14:54
    
Why not using a standard AD account to execute the service ? –  Mathieu Chateau Feb 3 '10 at 14:54

1 Answer 1

up vote 1 down vote accepted

The "NT AUTHORITY\NetworkService" account (well-known SID S-1-5-20) has its own HKEY_USERS subkey (HKEY_USERS\S-1-5-20) where its per-user settings are stored. You could specify your proxy settings in its registry (HKEY_USERS\S-1-5-20\Software\Microsoft\Windows\CurrentVersion\Internet Settings). I'm not aware of a place in the GUI that you can do this, but setting this via the registry isn't too difficult (here's a nice introduction to the registry values associated with proxy settings).

share|improve this answer
    
Thanks for the answer, I have tried this and restarted the service, but still get the same error. Does the machine need to be restarted? or maybe the problem lies elsewhere. –  Shiraz Bhaiji Feb 2 '10 at 14:51

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.