Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We are using a Dell desktop machine with 2 GB RRAM & Pentium D 3.00 GHz.

The machine is very slow when using our Sales program and searching over the local network.

We have this problem on 2 machine which are the same spec - This one and another.

All of our other machine (10) run fast with no issues.

Our server is SBS 2008 and AV is AVG. All of our client machines are WinXp Pro SP3 using the latest drivers.

Any ideas?

share|improve this question
    
Are all of the other machines similar specs? The Pentium D is known to run hot, so you might be experiencing heat-related problems in processor intensive applications. Note that processor intensive doesn't necessarily mean "high performance". –  Joe Internet Feb 2 '10 at 15:49

3 Answers 3

up vote 0 down vote accepted

Check that the network card drivers are the proper version and the network cards are set to the same speed (autonegotiation can cause glitches in switches).

Check that output from sysinternals tools like procmon and the procexplorer are matching on the two machines when performing the same task.

Nothing in the system logs?

Wireshark to monitor traffic over the wire, see if they're the same?

Checked for malware using spybot (you already said you have AV, is it updated fully?)

Anything odd with the hard disk, chkdsk finding issues, etc.?

share|improve this answer

What do your DNS settings look like? Are they the same as the other machines?

share|improve this answer

I've had similar issues and I've done the following: 1. See if power management is turning off or slowing down the performaince of your NIC. 2. If you have multiple NICs, change the priority of the default NIC, under the advance options of "Network Connections". 3. Change your NIC's link speed from "auto" to either 100full or 1Gfull.

Hope it helps. Thanks.

share|improve this answer
1  
-1 for suggesting random changes to NIC link speed without explaining what that means. I hate encountering systems that have their link speed hard-coded for no good reason because some engineer though it would be a good idea to try it out. –  Jed Daniels Jun 17 '10 at 5:02

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.