Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

With a setup of two NICs on a server into two different switches where each NIC has a different IP (But both on the same network), and then the switches to the router. How would I configure the two ports on the router to be redundant so that one port goes to one switch and the other port to the other switch. The router is a Cisco 3825, switches are Dell Power connect 5324s.

The idea being that as long as applications on the server are configured to work with both IPs, any 1 NIC or 1 switch could fail and the service would still be up. I understand the router would still be a single point of failure.

Update:
Little background, I moving my whole datacenter and don't have that much time to plan, so this sort of redundancy might be out of the scope of what I can learn and do with the time I have.

However, I am going to be rewiring everything and maybe purchasing stuff. I almost have enough switches to connect all servers to two different switches, and have a 3800 and a spare 2800 router. If I keep configurations as they are now, but put the second NIC into a redundant switch for each server, and then those second switches into the second router, will I be ready to set up this sort of redundancy as far as physical configuration is concerned? Might this configuration be limiting in my redundancy options, or which route I go will this basically be the physical layout?

share|improve this question
    
Next comes the question about VRRP / HSRP, eh? >smile< BTW, are you sure about the model number of the router? –  Evan Anderson Feb 2 '10 at 20:55

3 Answers 3

up vote 2 down vote accepted

You are going to have to setup dot1q trunking between the switches and the router (BTW did you mean 3825?) and then create a vlan interface on the router. You will not be able to have two router interfaces within the same IP address subnet otherwise.

You may need a switching module in the router for this to function as desired -- such as the NME-16ES-1G.

[edit / additional information]

You will not be able to have two router interfaces in the same subnet unless you either: (a) use a BVI interface as Vatine suggested (there are performance and other considerations using them however) or (b) put the two physical interfaces into a vlan (see example below).

!
interface FastEthernet0/3/0
 switchport access vlan 10
 switchport mode access
!
interface FastEthernet0/3/1
 switchport access vlan 10
 switchport mode access
!
interface FastEthernet0/3/2
 switchport mode access
 shutdown
!
interface FastEthernet0/3/3
 switchport mode access
 shutdown
!
interface Vlan10
 description Server_Vlan
 ip address 192.168.10.1 255.255.255.0
!

If you have two routers, then you could provide IP address/gateway redundancy for the servers by using HSRP, VRRP or GLBP.

[edit / additional information (HSRP example)]

interface Vlan10
 description Server_Vlan
 ip address 192.168.10.2 255.255.255.0
 standby ip 192.168.10.1
 standby priority 150
 standby preempt
!

For your second router, change Vlan10 to ip address 192.168.10.3 and a priority of 140. Use the command "show standby brief" on both routers to confirm HSRP operation.

share|improve this answer
    
Thanks Peter, I actually am using one of those now (a 4 port one). But could explain this a little more to the particular example I gave? I still don't really see how this all fits together... –  Kyle Brandt Feb 3 '10 at 12:47
    
Actually have an extra 2800, would I be able to provide the HSRP redundancy with one 2800 and one 3800? –  Kyle Brandt Feb 3 '10 at 13:50
    
Thanks for the update, updated my question again. As I read more about this, I think my goal might be to have the physical layout to build to redundancy first. –  Kyle Brandt Feb 3 '10 at 13:56
    
Sorry my question is a moving target :-P –  Kyle Brandt Feb 3 '10 at 13:56

Why not setup NIC teaming or bridging on the NICs on the server so that both NICs on the server share a single IP.

You shouldn't need to do anything special to the ports to make sure this works. As long as the switches aren't cross connected to each other you shouldn't even need spanning tree turned on.

share|improve this answer
    
Wasn't sure if worked like that, been having trouble finding reading material about teaming nics when each NIC connects to a different switch, so reading material (links) for that aspect would be appreciated. But with that setup, the question would still stand... –  Kyle Brandt Feb 2 '10 at 19:58
    
One advantage to the duplicate IPs might be that it would encourage a change in our applications to make them multiple IP ready, so maybe expanding them to redundant servers would be easier in the future. The teaming was my original thought though. –  Kyle Brandt Feb 2 '10 at 20:01
    
@Kyle Brandt - What platform are you using on most *nix varients you should be able to use NIC bonding and aliasing to achieve both "teaming" and multiple ips simulaneously. If your on a windows platform a lot more depends on your NIC drivers and control software. –  Jona Feb 2 '10 at 20:39
    
Jona Both, but right now my question is really more about between the router and the switches, not switches to servers. –  Kyle Brandt Feb 2 '10 at 20:40

One way would be to configure a bridge-group on the router and set a single default gateway as the IP address of the resulting BVI interface.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.