Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a Dell Power Edge 6850 with 2 physical Dual Quad Core Processors and 24GB of Ram as our VMWare Host Server. We have VMWare Server (Old GSX) installed on this box and have 5 Virtual Servers (Guests) running. The Guest OS's are running off of a Dell MD1000 Array connected via Dell Perc 5e card. The drives are Satau 7200 RPM. All of these Servers run Windows Server 2003 R2.

The problem we are having is that when we read from or write to the VM (Guest OS) the processor usage jumps to between 80-100%. I used Process explorer and saw that Hardware Interrupts are what is jumping. I know this is a Disk I/O issue (I have used tools to verify the disk write backs) My question is where is the bottleneck occurring? Is it at the SCSI card, the Array or the drives themselves? I seem to think it is the drives, but does anyone know of a way to verify this? Any input would be appreciated. Thanks, Erik

share|improve this question
    
I have also experienced this problem. It happens with new small images, and it doesn't seem to matter if the drives are RAIDed –  GreenKiwi May 21 '09 at 18:20

5 Answers 5

I had similar problems, and it was due to extreme disk fragmentation of the RAID array. Solution : create a crontab to defragment it every night. It works somewhat better now.

share|improve this answer

Are the drives SATA? SAS would be more suitable in this scenario.

Merits of SAS v SATA

share|improve this answer

I suspect this is not HDD issue, but a GSX Server issue. Its development was discontinued in 2005, when QUAD core processors where still non-existent. At most It should support only two processors with two cores each.

My suggestion is for you to switch to Vmware ESXi: it can be installed on bare metal, has good hardware support and is completely free. You can use a paid version of course (VShere 4), if your boss will not faint after seeing an invoice from VMWare :)

I believe PowerEdge servers come with ESXi preinstalled nowadays, so you can find more info on Dell's site.

share|improve this answer

Running ESXi instead of VMware-server will give you a HUGE performance boost. In either case I bet your second proc isnt licensed, IE, its not being used.

share|improve this answer

Are you using a disk image ( File living on top of the filesystem) ? In that case, the disk image file may have become fragmented over time. There might be tuning options that might help to, for instance, disabling atime ( access time in Linux, I think you can disable this in windows as well ).

Are your drives in a raid configuration?

share|improve this answer
    
I haven't tried running it on bare partitions yet. Maybe that will make performance reasonable. –  GreenKiwi May 21 '09 at 18:20

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.