Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm running a Linux server named S1 in a "cloud" server, and when tomcat 6.0.24 starts, I get the exception:

org.apache.catalina.connector.Connector pause
SEVERE: Protocol handler pause failed S1: S1
    at org.apache.jk.common.ChannelSocket.unLockSocket(

Which then leads to:

ERROR ehcache.Cache  - Unable to set localhost. This prevents creation of a GUID. Cause      was: Sjira1: S1 S1: S1
    at net.sf.ehcache.Cache.<clinit>(

My hosts file is:     localhost localhost.localdomain
(valid-ip-address)     S1 S1.(valid domain name)
  • ping S1 and S1.(valid domain name) return valid ip address
  • nslookup S1.(valid domain name) returns valid ip address
  • nslookup S1 throws ** server can't find S1: NXDOMAIN

Any ideas about how to fix this ?


share|improve this question
up vote 1 down vote accepted

Solved ... added "search (domainname)" to resolv.conf

share|improve this answer
I'm getting the same problem. Did you add search (S1) or search S1 to resolve.conf? – Josh K Jan 13 '11 at 2:46
Actually "search (hostname.domainname)" – xain Jan 18 '11 at 2:06

I had this exact same error and tried your suggestions. Tomcat would start without any errors but my webapp would just hang. The fix I had, which is really strange, was to cd to ${tomcat_home}/bin first and then execute the When I reverted back to the original hosts and resolv.conf files and applied this fix, it worked fine. Weird.

share|improve this answer

Most likely S1 does not resolve to an IP using a name server only.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.