Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm using ProFTPD 1.3.1 Server on Linux. Currently when you upload files via FTP the files have the permissions mode of 664. I would like to change this to default files to 775 instead.

The aim is to allow users that are in the same group as the group that owns the file(s) to be able to edit and replace them.

By default (664), only the original user can edit and replace the file.

share|improve this question
add comment

2 Answers

up vote 2 down vote accepted

I would imagine that would be in a configuration file, a quick google search tells me that the configuration file is called proftpd.conf.

edit the umask values in vi or something to set the permissions you need.

heres a link to what a basic proftpd.conf file would look like so you know where to look to set the uMask. http://www.proftpd.org/docs/configs/basic.conf

Hope this helps.

share|improve this answer
    
I've set the umask setting to 002 002 in the config file but it still seems to be uploading files as 664. –  Camsoft Feb 3 '10 at 15:18
    
Your FTP client may also be setting a umask which would override the config file's default. Try umask 002 in the FTP client. No clue how to set it from GUI FTP clients, or if some (IE) even let you... –  voretaq7 Feb 3 '10 at 15:21
    
I'm using Filezilla for Windows.I can't see any setting that would suggest it overrides the systems default umask values. –  Camsoft Feb 3 '10 at 15:27
    
I would hope FileZilla wouldn't blindly override the default, on the off chance it does forum.filezilla-project.org/… (the magical undocumented way of executing arbitrary commands like umask after login) may be helpful –  voretaq7 Feb 3 '10 at 15:38
2  
under normal scenarios, even if the umask allows it files are created without execute (as it'd be a security risk), and so the 1s bit in the umask only affects directory creation. –  Joe H. Feb 3 '10 at 15:56
show 5 more comments

First you say "644" then you say "664". Shouldn't that be the difference between user-writable and group-writable? Why should execute permissions be needed? I would recommend against that for security reasons.

share|improve this answer
    
It was a typo, this has been corrected now; it should be 664. I used 775 because this allows the owner and group to read / write. I was not sure if I needed execute or not as they are mainly .php files. –  Camsoft Feb 3 '10 at 15:54
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.