Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I installed Postfix with ubuntu 9.10, apache2 and php5. I have an e-commerce website that sends out emails using the postfix installed on the server. Do I need to perform any special configuration on postfix to ensure out-going mail with sensitive information is secure?

I installed Postfix with the command

sudo apt-get install postfix

The PHP mail() function worked immediately afterwards, so I did not modify postfix's default configuration. Do I need to do more for security?

share|improve this question
    
There is a similar question with an answer providing other good hints. –  lumbric Jan 1 '12 at 22:57

1 Answer 1

up vote 0 down vote accepted

You must always check the configuration of the MTA. Anyway, if you bind Postfix only to 127.0.0.1 with inet_interfaces parameter, you can be quite sure, but never rely on defaults.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.