Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I want to setup a linux vm with apache and php and mysql support, which version of linux should I pick up.
I dont have a good bandwidth, preferably a smaller ISO of the installer is also appreciated.

share|improve this question

6 Answers 6

Would WampServer or Xampp be an option instead of a full VM?

share|improve this answer

What about Turnkey LAMP appliance?

share|improve this answer
    
This is a very good one, do you think installing any popular PHP editor on this VM will be easy? –  John G Feb 11 '10 at 13:26
    
there's already vim on it, in case you want to edit source directly on the VM. If you're more comfortable with another more graphical IDE, you should probably not work directly on the VM. –  clement Feb 12 '10 at 10:15

Debian base is what I have used in the past but you can also do a stripped down install of centos for example. The distribution is immaterial really. Choose one that you are comfortable with and then just do the bare minimal install. In fact, if you don't intend to be compiling anything, you wouldn't even ever need to install the kernel sources, make, gcc or any of its brethren. The netinstall variants can be used if you don't mind that it will simply download the basics that are needed for the install. Or you could always try freebsd. :) (No this is not a freebsd vs linux flame. please do not interpret it as such.)

share|improve this answer
1  
Agree. Debian has a really small footprint by default but enough packages to work along with it. –  Antoine Benkemoun Feb 4 '10 at 8:48

I have no rep, but I would vote for Chiefbrownbottom.

share|improve this answer
    
Thanks, I can vote now and stuff. :) –  Prof. Falken Oct 12 '10 at 8:15

You could use a net install of Debian. You only have to download a little bit at the start and then you apt-get install what you want. This way you won't download something you don't need.

share|improve this answer
    
please use aptitude nowadays for that –  ThorstenS Feb 12 '10 at 6:11

Use this install Image: http://cdimage.ubuntu.com/jeos/hardy/daily/current/hardy-jeos-i386.iso

Open Console:

sudo apt-get install mysql-server-5.0 libapache2-mod-php5 php5-mysql phpmyadmin 

finish :)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.