Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Has anyone else had issues with IE8 taking it's own sweet time starting up and/or hanging?

I have a couple of machines on my network that won't start up quickly (like over a minute to load). I've disabled the 'Accelerators' included, but it still takes quite a while to open it up (if at all).

Has anyone else encountered this? If so, any ideas on how to speed up the startup?

Thanks! -JFV

EDIT: This is happening mostly on my WinXP SP3 computers and some on Vista 32-bit systems. Hardware is beefy enough to handle this with dual-core procs and 3gig RAM.

share|improve this question
    
What OS? For me, I've noticed that on my Vista x64 machine opening new tabs with IE8 is painful, but on the XP and Win7 machines everything is zippy. –  Chris_K May 21 '09 at 19:27
    
Have you tried starting it with no add ons? –  notandy May 21 '09 at 21:16
    
@notandy: Yes, still slow coming up. –  JFV May 21 '09 at 21:35
add comment

7 Answers 7

up vote 3 down vote accepted

I haven't had the problem but I remember that Ed Bott did some investigation and has specific recommendations on "slow to start" ie8. Here's the link: Ed Bott and slow IE8

share|improve this answer
    
Thanks for the link. It's still slower than I'd like it (remember the good old days when it would pop up within a second?), but it is coming up faster than it was! –  JFV May 27 '09 at 11:35
    
The other thing to check is to make sure Java is disabled. It's costing a few seconds each time a tab is generated. –  Knox May 27 '09 at 15:53
add comment

For the archives (since an answer has already been accepted.)

IE Slow Down.

With IE8's RTW release, users of the popular anti-spyware tool SpybotSD started having serious problems with IE's speed (from working as normal in the Beta and RC stages) to taking X minutes for startup and creating new tabs.

A problem was identified/highlighted by Safer Networking authors of SpytbotSD with IE8's handling of extremely large lists in the "Restricted Zones." Safer Networking's press-release references a Microsoft fix at KB969897 (released June 19th, 2009.

The finger pointing aside (as blame can be evenly divided between MS and SN) if you're having the speed issues and have SpybotSD installed, check the above references or update both pieces of software to their 'current' renditions as the problem seems to have been resolved.

Technical Summary:

  • SpybotSD "Immunize" feature stuff's IE8's Restricted Zones list with a lot of sites.
  • The list isn't designed for this use (abuse?)
  • MS Changes the base code used within the Restricted Zones functionality to support new web standards directions.
  • "Restricted Zones" feature slows insignificantly for a short list, but significantly for the huge lists generated by SpybotSD's "Immunize" feature.

Technical Solution:

  • Do not use IE8 -or-
  • Disable SpybotSD's "Immunize" feature (i.e. if you've already used it, undo it!!)
  • Use IE8's "Smart Screen Filter" (use it anyway, even if you want to use SpybotSD.)

I run 'current' versions of IE8/SpybotSD and Windows 64bit 7RC1 without problems, where I remember disabling spybotsd to get IE8 RTW functional in Vista 32bit.

share|improve this answer
add comment

You can usually take 1-2 seconds of start up if you disable 'Java 2 SSV helper' - i've never found a satisfactory description of what it does - the only thing i can see it do is slow down the opening of IE windows.

share|improve this answer
    
I'll try that to see if it helps. Thanks for the tip, I haven't heard of that one... –  JFV Jun 8 '09 at 22:33
    
Ditto for "MS Research" - its incredibly slow and doesn't do anything useful. –  scunliffe Jan 22 '10 at 15:11
add comment

I've seen it on WinXP SP3 computers. I was told by some people I trust that it has performance issues on WinXP systems. I ended up uninstalling it. I realize this didn't answer your question about how to improve, sorry.

share|improve this answer
add comment

Disable unnessary IE plugins such as toolbars and the like. Make sure that you defrag your HDD and delete temp files via CCleaner

share|improve this answer
    
Base IE config with no 'accelerators'. The only toolbar added is the Google Toolbar, but this issue occurred even before installing IE8. –  JFV Jun 8 '09 at 22:31
add comment

I've noticed slow 32bit IE8 performance on startup and slow opening of new tabs. With the x64 version it's lightning fast.

Still trying to figure out why - applied all the so called fixes.

Bob the Builder

share|improve this answer
add comment

Do you have autodetect proxy turned on?

share|improve this answer
    
No, I have that turned off. It hasn't been needed by any clients I've ever used. –  JFV Jun 8 '09 at 22:29
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.