Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

We're running Windows Vista Enterprise as a guest OS under Microsoft Virtual PC 2007 SP1 ( (running on Windows XP Professional host). Our development workstations have multiple monitors, including a widescreen that supports 1680 x 1050. The developers like to run the guest OS in full screen by using the right alt-enter feature and be able to maximize the screen real estate.

However, when I go to Control Panel > Personalization > Display Settings to change my resolution, I don't have 1680 x 1050 as an option: it goes from 1600 x 1024 to 1600 x 1200. The monitor is reported as "(Default Monitor) on VM Additions S3 Trio32/64", which matches the emulated video card from Virtual PC. The 1600 x 1024 setting leaves an area of the screen unused.

I think I could edit C:\Windows\inf\monitor.inf to add the new resolution, probably under the [Generic.NTx86] (*Monitor\Default_Monitor is the hardware device ID for legacy descriptor-less monitors*.). However, I'm not sure exactly what to change. Switching from Virtual PC to VMWare Workstation or another product is not an option.

share|improve this question

This is not possible due to the limits of the virtualized video card that virtual PC virtualizes.

one workaround that I have seen mentioned but never tried was to boot up your virtual PC and then remote desktop to that PC. seems cumbersome and resource wasteful to me though.

share|improve this answer
Upvoted for remote desktop. I wouldn't mind the overheard incurred using RD. It's all (bridged) network traffic on the same NIC (presumably), and you get the proper resolution for a very small cost. – p.campbell Jun 2 '09 at 23:02

I'm using Virtual PC 2007 SP1 ( with an XP guest. Right-alt-enter successfully puts the VM into 1680x1050 full screen mode. It appears I got the update to from a hotfix rollup package (KB958162):

The resolution is now extended to 2048x1920 (32bit). Virtual PC 2007 SP1 supported a screen resolution of up to 1600 x 1200.

Note that KB958162 also includes a new version of Virtual Machine Additions.

1680x1050 is also available in the guest's Display control panel, but selecting it causes a dialog (in the guest) that says "The display control panel is unable to change the display settings. You must have the appropriate administrative rights to change these settings." After that, 1680x1050 is no longer available.

share|improve this answer
This suggestion about installing the SP1 hotfix worked perferctly – PeterToTheThird Jan 2 '13 at 19:15

Don't ask me why this works, but it works (after applying the hotfixed in bk1e's post).

  1. Set the VPC to windowed mode
  2. Inside the VPC, set the screen resolution as low as it can go (800x600 for me).
  3. Drag the VPC window to the edges of the monitor
  4. alt-enter to go fullscreen. VPC is now at 1680x1050. It doesn't seem to stay after re-starting Virtual PC, though.
share|improve this answer

It might be worth trying Powerstrip ( It seems a bit of sledgehammer to crack a walnut, but it's a free evaluation so you could see if it works.

John Rennie

share|improve this answer

Have a look at VirtualBox. I find it runs quicker than Virtual PC and I have used it with 1680x1050 before no problems. I use it for development all the time, currently with a Win7 guest.

share|improve this answer
up vote 0 down vote accepted

Today I had luck and it went full screen. When I checked Control Panel > Personalization > Display Settings, it was set at 640 x 480, which is the low point on the slider. I think it has to due with the Virtual PC Console Settings > Display where "Virtual machine window resizing options" is set to "Allow any screen resolution."

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.