Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm running Windows 7 (32-bit) as a development workstation. Either software I've installed today (SQL Server 2008) or new software I'm working on and testing with NUnit is causing the Windows 7 shell to lockup. Windows Explorer windows will show the "(Not Responding)" message in the title bar. Occasionally some windows will remain slightly responsive (like a remote desktop session to corporate office systems).

I'm not able to right-click on the task bar or CTL-ALT-DEL to bring up Task Manager. There's no evidence in the event logs to suggest what is actually happening. At present the only solution to deal with the event is to power cycle the system. I'd prefer not to do that.

Is there anyway to bring up Task Manager in Windows 7 when the the task bar and CTL-ALT-DEL are not responding? If so, how?

Update: Using Mathieu's suggestion, I brought up SysInternals' ProcessExplorer before running the tests. When the tests completed and I tried to close NUnit I saw that the window closed. The NUnit process stayed running. Other windows, like Windows Explorer, were once again frozen. Trying to kill the NUnit process with ProcessExplorer caused ProcessExplorer to hang. So, clearly, it is some of the code that is under test that is causing NUnit to not exit cleanly.

Now if I could just get the system back to a functioning state without having to power cycle ...

share|improve this question
You misunderstood Mathieu's suggestion. You used Process Explorer, which is a great tool, but he had suggested that you use Process Monitor (also from Sysinternals), which will give you much more granular information and you may find out what in the code is locking you up. – mfinni Feb 4 '10 at 18:51
Fair enough. I did download ProcesMonitor, set it to capture events just before closing NUnit, and began watching it. When the NUnit window disappeared from the screen I went to ProcessMonitor to see what happened. ProcessMonitor locked up. – Mike Chess Feb 4 '10 at 19:23

Any luck with Win + R to bring up Run, then if so try to launch "taskmgr" that way.

If you have a working explorer window, use "C:\WINDOWS\system32\taskmgr.exe"

but outside of these two options, Right Click -> Task Manager, CTRL+ALT+DEL and CTRL+SHIFT+ESC you can't do much more.

share|improve this answer
I haven't tried Win+R in this context. The shell has been unresponsive, so I would expect that it wouldn't work either. I'll endeavor to try it as I work through this. – Mike Chess Feb 4 '10 at 18:25
Win+R does not work. :( – Mike Chess Feb 4 '10 at 18:43
That is a shame :( options are limited after that. Really not much more you can do beyond the methods I listed above. – Urda Feb 4 '10 at 21:16

you could use ctrl + shift +esc

but i guess it won't work better, as even the sas sequence is not working.

You could either use process monitor from sysinternal (launched before the hand) or enable the crashOnControl to get a memory dump and so find what's hanging the system that way

share|improve this answer

This might be overkill, but if you're comfortable with kernel dumps you can force a blue screen memory dump from the keyboard and then look at the memory dump file...

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.