Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

i am SSHing to a RHEL-3 box using Putty. Backspace works correctly, but when I press the "Delete" key the deletion does not happen. Instead, it prints "~" on the screen.

Thanks in advance, Ajay

share|improve this question

Have you tried changing your options in the PuTTY keyboard pannel?

Alternatively, you can try to create a ~/.inputrc file on the RH box, with the following contents:

"\e[3~": delete-char

Once you've created the ~/.inputrc file, restart the shell.

share|improve this answer
    
This didn't work :( – user29639 Feb 4 '10 at 21:59
    
You probably forgot to restart the shell. (^X ^R also works.) Also, it's supposed to be ~/.inputrc - in your homedir, not in /. – grawity Feb 5 '10 at 13:24
    
This worked for me in the shell, but VIM still has the error. Thanks for the help! – Diablomarcus Jan 12 '11 at 16:54

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.