Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

This is the first time I've played with IIS and FTP. We have around 2000 users in AD. Each of these users has a share on the network, all under a root folder, labeled with their username.

Ex:

\\network\john.doe
\\network\jane.doe

I'm trying to setup an ftp server in IIS 7 to allow users access to their directory and only their directory. Kind of like a web host, where I sign up for an account, login with ftp and get directed to my own folder. The only difference here is that we don't have to create directories, they already exist.

Here's what I've got:
- ftp site in iis that points to the root directory "network" that contains all the user directories
- basic authentication and filled in the domain
- authorization (all users) for testing purposes
- ftp user isolation -- username directory checked

Now I understand the last option is NOT what I want because it allows the user to move up to the root. However, this is the only option that allows me to login successfully and directs me to my folder. If I select either of the isolate users options (disable global or enable global) I cannot login. No message, just the authentication prompt keeps reappearing.

What am I missing here?

share|improve this question

2 Answers 2

Isolated FTP usually requires the DOMAIN as the first part of the "user share" - ref: http://learn.iis.net/page.aspx/305/configuring-ftp-75-user-isolation/

To create home directories for each user, you first need to create a physical directory under your FTP server's root folder that is named after your domain or named LocalUser for local user accounts. Next, you need to create a physical directory for each user account that will access your FTP site.

%FtpRoot%\LocalUser\%UserName% (non-domain)
%FtpRoot%\%UserDomain%\%UserName% (domain)
share|improve this answer
    
Is there any way to edit the format of that? I have ftproot\username. –  Beavis Feb 5 '10 at 14:03
    
+1. And note that the directory does not need to be physical. I just tested my setup with physical paths c:/wwwroot/userXXX and ftp virtual directories /fabricam/userXXXX. You can create virtual directories within virtual directories. –  Salman A Nov 23 '12 at 11:38

Have you set appropriate permissions on the root and user directories? Appropriate permissions + isolated mode is generally the way to do it.

share|improve this answer
    
Ok, this is going to sound stupid but (network isn't my strength) -- these directories are accessible/authenticated via active directory. I set basic authentication and supplied the name of the domain. When I navigate to the ftp site I'm prompted for my windows auth...am I missing something? –  Beavis Feb 4 '10 at 21:27
    
Here's one thing - in the basic auth settings where I specify my domain. What format should it be in? Let's say I login to Windows with CoolDomain\john.doe...I just put "CoolDomain" in there or is there a diff format needed? –  Beavis Feb 4 '10 at 21:30

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.