Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Started with 5.2.6 installed, then proceeded to install 5.3.1, but instead of overwriting, SSH php is now running 5.3.1, whereas the web server still servers content with the 5.2.6 installation.

Any ideas about how to correct this? I basically need to locate where the two separate installations are and correct, but I've only been able to find 5.3.1 in /usr/bin/

Big help needed here guys :)

CentOS 2.6.9, Lighttpd

[root@server ~]# rpm -qa |grep php
php-gd-5.2.6-1.el5.art
php-imap-5.2.6-1.el5.art
php-snmp-5.2.6-1.el5.art
php-mbstring-5.2.6-1.el5.art
php-ldap-5.2.6-1.el5.art
php-cli-5.2.6-1.el5.art
php-xmlrpc-5.2.6-1.el5.art
php-mysql-5.2.6-1.el5.art
php-common-5.2.6-1.el5.art
php-ncurses-5.2.6-1.el5.art
php-pdo-5.2.6-1.el5.art
php-xml-5.2.6-1.el5.art
php-odbc-5.2.6-1.el5.art
php-mhash-5.2.6-1.el5.art
php-mcrypt-5.2.6-1.el5.art
[root@server ~]# php -v
PHP 5.3.1 (cli) (built: Nov 26 2009 03:27:03)
Copyright (c) 1997-2009 The PHP Group
Zend Engine v2.3.0, Copyright (c) 1998-2009 Zend Technologies
share|improve this question
    
To provide more details it would be helpful to know the OS, what the OS version is. Also would be useful to know how precisely 5.2.9 was installed and how you attempted to upgrade 5.3.1 –  Zoredache Feb 5 '10 at 19:00
    
Updated my original post. 5.2.9 came with the server by default, and with 5.3.1, I have honestly forgotten now unfortunately. –  James Feb 5 '10 at 19:16

1 Answer 1

The web-server module or cgi php is mostly separate from the cli version.

It sounds like you upgraded the cli version of php, but didn't update the web server module/cgi version.

share|improve this answer
    
See above -- your webserver is probably running PHP as a module, and your new PHP install either didn't build the module or didn't put it where Apache expects it. Double-check your Apache configuration. –  voretaq7 Feb 5 '10 at 19:22
    
Also I'm guessing you built PHP 5.3.1 from source (since your RPM list still shows 5.2 packages) -- If you're installing PHP from source you should remove the RPM packages to avoid unplesant surprises (redhat "upgrading" the 5.2 packages and overwriting/breaking your 5.3 installation.) –  voretaq7 Feb 5 '10 at 19:24
    
Ah that does sound around right. Any ideas how I should set about doing this guys? :) –  James Feb 5 '10 at 19:57

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.