Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have my web server on a domain and everything is fine until I try to browse to site.

I have given the DOMAIN\MACHINE$ rights to the virtual directory and the app pool identity is Network Service.

I get this error when I test these settings:

The server is configured to use pass-through authentication with a built-in account to access the specified physical path. However, IIS Manager cannot verify whether the built-in account has access. Make sure that the application pool identity has Read access to the physical path. If this server is joined to a domain, and the application pool identity is NetworkService or LocalSystem, verify that domain\computer_name$ has Read access to the physical path. Then test these settings again

share|improve this question
    
Is the virtual directory pointing to a directory hosted on another server? –  Jeff Feb 5 '10 at 22:55
    
no. the sql server is on another computer in domain. so instead of Network service i enter Domain\LOCALMACHINE$ but still get error –  zsharp Feb 6 '10 at 0:34

1 Answer 1

This sounds like a delegation issue. I would first enable kernel mode authentication, then make sure that the computer account is trusted for delegation

share|improve this answer
    
how exactly to do that –  zsharp Feb 6 '10 at 0:55
    
Here's an article regfering to the certificate services buthe the way delegation is configured is exactlythe same: blogs.technet.com/askds/archive/2009/04/22/… –  Jim B Feb 7 '10 at 17:13

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.