Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Recently, I did a distro upgrade on my Ubuntu 9.10. The process result in mnemosyne, my favorite flash cards program being removed, since it depends on python-qt3 - which was removed as a result of the upgrading process. When I tried to install python-qt3, I got this error message:

The following packages have unmet dependencies:
  python-qt3: Depends: python-sip4 (<= 4.10) but 4.10.0-0ubuntu1~karmic1~ppa1 is to be installed
E: Broken packages

In such cases, what should I try so that I can install back my mnemosyne?

share|improve this question

2 Answers 2

up vote 1 down vote accepted

It looks like you are running python-sip4 from a backports repository. Is that correct?

Karmic version: http://packages.ubuntu.com/karmic/python-sip4

Backport: https://launchpad.net/~kubuntu-ppa/+archive/beta/+index?start=75&batch=75

I would install apt-show-versions and then checkout what python-sip4 packages you can install from the various repositories you have configured:

apt-show-versions -a python-sip4

Then try installing the core Karmic version that is listed in the apt-show-versions output:

aptitude install python-sip4=4.9.1-snapshot-20091015-0ubuntu1

Unfortunately this may cause even more problems, especially if you are using packages from the backport repository which requires the newer version of python-sip4.

Plus, the next time you run apt-get upgrade it will probably want to upgrade to python-sip4 4.10. Therefore you'll either need to remove the backports repository, or put a lock on the version you've currently got installed.

Your best bet would be to remove any third party repositories you have installed, revert your installation back to something that is 'pure' Karmic, and move forward from there: http://it.toolbox.com/blogs/locutus/how-to-revert-to-a-pure-debian-system-25978

(This article refers to Debian, but it is equally applicable to Ubuntu)

share|improve this answer
    
Thanks, I have down-graded my python-sip4 and mnemosyne was successfully installed. –  Phuong Nguyen Feb 7 '10 at 10:01

Can mnemosyne be built from "source" with the newer libraries plus dev packages installed?

If not,as much as i hate to recommend it: Cleanest solution is to make (from source) a local version (DO NOT install to /usr/local!) of python including the library chain your application needs, as well as a local version of the application (also from source, and with the right build arguments to make it use your local python).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.