Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am working on a development server with a bare-bones installation of SharePoint 12.0.0.4518 (WSS 3.0 RTM). Knowing very little about SharePoint development, we installed the environment atop a SQL Server Express 2005 database. Now I am running into that 4GB limit. The site is just a simple installation that I've been testing a custom web part on; apparently, in removing and reinstalling the web part, the cached copies have completely filled up the database. It is so full, in fact, that I can't even delete content without throwing an error message, so my site has become unusable.

My question is: how do I proceed? I was going to split the content database but that's not possible in its current state. Upgrading to SQL Server is not an option for us. I had thought of going to WID; however, I'm not sure how to do anything at all with this database since everything I try throws an error related to the database being full (HRESULT: 0x80004004 (E_ABORT)). I just don't know how to proceed. Thanks for any help!

share|improve this question
    
When you try to delete things, are you doing it through the web interface or via STSADM? Also - how were you deploying your custom web part? Through the WP gallery, or using STSADM? –  MattB Feb 8 '10 at 17:53
    
I had initially tried to delete via Central Administration; now I can't even open the site without the HRESULT error. My custom web part was being deployed via WSSBuilder, so it's going to /bin and being displayed in the Web Part Gallery. –  Geo Ego Feb 8 '10 at 18:15
    
One other question - if you look at the database files, is the space in the log files (LDF) or the data files (MDF)? If it is in the log files, you might be able to do a log backup/truncate to free up some space. –  MattB Feb 8 '10 at 19:24
    
The space is, unfortunately, in the database files. I did initially shrink everything ... probably about two weeks ago. Everything ran fine after that, and I deleted the umpteen web part copies via Web Part Maintenance, and I had assumed that this would be a solution I could use when I ran into this problem. This time, however, I didn't run into a problem until the data became so large that I am apparently unable to do anything with the db without hitting that cap. –  Geo Ego Feb 8 '10 at 19:30

2 Answers 2

up vote 1 down vote accepted

I would first try removing the web part (and solution) using STSADM commands rather than the web interface.

If that fails - in the interest of gaining some space back - how about disabling (and therefore emptying) the recycle bin? That might get you enough space back that you can do some clean up work. (This of course means that you lose your entire recycle bin history - hopefully on your dev server that isn't an issue.)

Also - if you can get it fixed, definitely switch to WID, there is no size limit like with SQL Express.

share|improve this answer
    
Yikes. Removing web parts and trying to disable the recycle bin via stsadm both fail because of the full database. Is there a simple way to perhaps restore this content database to the default state, as it was after installation? There is nothing in the site that I can't afford to lose; it's just a sandbox right now. –  Geo Ego Feb 8 '10 at 21:22
    
stsadm deletecontentdb technet.microsoft.com/en-us/library/cc262449.aspx –  MattB Feb 8 '10 at 21:51
    
Tried deletecontentdb as well, and it's also throwing an HRESULT exception. Almost everything that I do is, in fact. Right now, I'm working on manually uninstalling WSS and reinstalling WSS with WID. –  Geo Ego Feb 9 '10 at 16:20
    
Sheesh. Nothing but problems. Successfully uninstalled WSS. Reinstalling with WID is proving to be a nightmare. Error 26 and 18456 all over the place, just can't connect to the newly created ##SSEE. Enabled remote connections via TCP or named pipes (even though I'm connecting locally). Gave the user the proper permissions. Set up TCP properly. This is turning out to be a massive pain. –  Geo Ego Feb 9 '10 at 21:26

Try using a VM with a full installation of SQL Server. Restore the content database to that and fix it. Take the fixed and smaller database and restore back to production.

share|improve this answer
    
If we had a license for the full version of SQL Server, I'd just use that, since we're only going to run SharePoint on one box anyway. I can't bring SQL Server Standard or Enterprise into the equation at all because we're not going to purchase it. –  Geo Ego Feb 8 '10 at 21:20
    
Perhaps a trial version microsoft.com/sqlserver/2005/en/us/trial-software.aspx on the VM. –  Nat Feb 9 '10 at 0:22
    
That's a good idea. I'll keep this in mind; however, I'm working on uninstalling and reinstalling WSS 3.0 completely right now with WID so that I can avoid the problem entirely in the future. Thanks! –  Geo Ego Feb 9 '10 at 16:19
    
can't you use the developer edition? –  vitule Feb 11 '10 at 17:45
    
Yeah, but either way, that's not going to fix the problem, just delay it. Even if I install to SQL Server and fix up the database, it's going to get full again. Also, once we go into production, we're going to need more than 4GB in the entire content database, so offloading everything to SQL Server and then back to Express is just pushing the problem out to a later date. –  Geo Ego Feb 12 '10 at 17:44

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.