Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

My end users are not able to use autocomplete when they use a web application hosted on a particular server. Autocomplete is usually a client-side setting. My users can use autocomplete when they are on other websites so I think it is a server setting in this case. How do I turn autocomplete on for a server running Windows Server 2008? Is this a setting in IIS, a registry setting, a group policy setting, or something else? Thanks in advance.

share|improve this question
2  
I discovered this comment from Eric Lawrence, an Internet Eplorer program manager at Microsoft since 1994. msdn.microsoft.com/en-us/library/ms533486(VS.85).aspx Note: if both of the following conditions are true: 1.The page was delivered over HTTPS 2.The page was delivered with headers or a META tag that prevents caching ...the Autocomplete feature is disabled, regardless of the existence or value of the Autocomplete attribute. This remark applies to IE5, IE6, IE7, and IE8. This describes our situation. –  Tarzan Feb 10 '10 at 18:38

3 Answers 3

Any kind of autocomplete will be either a browser feature or an app feature and not a function of the server. It's possible that the app might use something that's disabled on the server, I suppose, in order to do its autocomplete but there isn't anything that is specifically for autocomplete from the server side.

share|improve this answer

Have you looked at web pages/web applications that you are serving to check if autocomplete has been disabled? Specifically you want to look for something like autocomplete="off" in the source of the pages you have served.

share|improve this answer
    
Thanks for your reply. I will be able to look at the web page source code tomorrow. When the pages are on a QA server the autocomplete works. It is only when the web pages are deployed to the production server that autocomplete stops working. That is what led me to believe it was a server setting. –  Tarzan Feb 8 '10 at 19:07
    
It turns out that autocomplete is not working on the QA server either. –  Tarzan Feb 10 '10 at 18:36

Just to provide a little more info than zoredache you need to look at the source and find something like:

<input type="text" name="ccnum" autocomplete="off" />

autocomplete is a client side setting but IE and mozilla based browsers use the autocomplete=off attribute to allow thing like credit card numbers not to be store in plaintext on the computer.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.