Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Somehow my desktop system has been infected with Roxio Media Manager... I say it that way only because the MSI is continually executing on my system and I can't make it stop. The install never succeeds because it apparently needs some resource that it can't access for whatever reason. I can cancel the install, but a few minutes later it starts up on it's own again. The only thing I've found that works is to just leave the installer running in a failed mode, but that stops me from running any other MSI based installs or uninstalls. I think this started happening after I uninstalled a bunch of software that I don't use from my machine, but I'm not 100% sure.

I've checked everything I can think of but ... there are NO Roxio anythings in my list of Add/Remove programs, I've run MSCONFIG to check startup files and there's no sign there of anything Roxio related (that's active, anyway). I've disabled any/all services that have "Rox" anywhere in the title.

Is there anywhere else that I should check to try to figure out why this MSI is constantly trying to install itself? I'm nearing the point of wiping my machine and starting over from scratch.

share|improve this question

2 Answers 2

up vote 2 down vote accepted

This seems to be a somewhat common issue if you currently or previously have had Blackberry software installed on your machine.

Here is a link to a similar question and answer on Roxio forums.

Good luck.

If that doesnt work....Is there a Roxio folder in Program Files folder? It has to be firing off from somewhere. Check your temp directories and the appropriate places in the registry. Also checkout the services that are starting up. Some may not have the word Roxio in them, but could still be associated with Roxio.

You could try installing whatever Roxio software CD you have and then uninstalling it.

EDIT - rewritten for clarity

share|improve this answer
    
Hmmm I did find a Roxio directory in Program Files and I deleted it. I also found a Roxio in the Registry and I deleted that too. I even emptied my Recyling Bin folder. The only change now is that the installer reports that it can't find a certificate file. Where in the registry should I be looking? –  Michael Bray Feb 9 '10 at 15:37
    
Ahh actually I didn't see the link you had... this stupid CSS that SF uses actually makes it harder to see links unless you specifically alter the formatting to make it obvious. I do have BlackBerry software loaded - I'm going to uninstall it and see if that helps. –  Michael Bray Feb 9 '10 at 15:46
    
Removing Blackberry Desktop along with some of the other things in forums.crackberry.com/f35/… seems to have solved it! Thanks! –  Michael Bray Feb 9 '10 at 17:09

Unfortunately there's still some components of the Roxio stuff left on your machine, possibly a misbehaving Explorer shell extension or similar. You could try using the Windows Installer Cleanup Utility to remove the Windows Installer related portions of it that are left over.

share|improve this answer
    
Good starting path... I have WIC installed previously. But if the program doesn't list in 'Add/Remove Programs' then how would I identify the particular item that needs removing?? –  Michael Bray Feb 9 '10 at 15:07
    
I wouldn't expect the offending program to show in Add/Remove Programs in cases where the cleanup utility is needed, so generally if you cross-reference one list with the other something obvious should jump out. –  Darth Satan Feb 9 '10 at 15:18
    
But MSIZAP is a command-line utility, and you need to know what you are removing to start with... as far as I can see, it doesn't have capability to list installed programs. How would I get the "other list"? Note that I tried downloading the tool you pointed me to and tried to install it just in case, but I CAN'T install it because this damn Roxio installer prevents another MSI from running. –  Michael Bray Feb 9 '10 at 15:34

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.