Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have set up a subversion server through Apache http (mod_dav_svn). I created a Subversion project at /usr/local/svn. I can check out the project via svn co http://host/svn. However, when I try to commit, I get this error:

svn: Can't create directory '/usr/local/svn/db/transactions/0-1.txn': Permission denied.

I tried changing the owner and permissions of /usr/local/svn (the repository) as follows:

chown -R apache.apache /usr/local/svn
chmod -R g-w /usr/local/svn

Unfortunately this does not solve the problem. Please help!

share|improve this question

2 Answers 2

I have almost the same setup and to make this work for all the application developers I used the following permissions

drwxr-xr-x 7 www-data www-data

my www-data user/group = your apache user/group

I also added the applications developers to the group www-data.

By the way, this is in my apache conf file (this keeps things more secure):

  <Location /somesite>
     DAV svn
     SVNParentPath /home/www/svn/somesite
     SVNListParentPath On
     AuthType Basic
     AuthName "Subversion Repository"
     AuthUserFile /home/www/svn/.htpasswd
     <Limit GET PROPFIND OPTIONS REPORT>
        Require valid-user               
     </Limit>
  </Location>

Test first that you can commit locally on your server and then remotely.

share|improve this answer
up vote 1 down vote accepted

I found the answer here.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.