Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I can install and run Sybase Central v 4.3 on Windows XP without issues.

However, I am not so lucky when I use 64-bit Windows Server 2008 R2. It does install but it will not run. I tried running in compatibility mode (Win XP) but it did not work.

Anybody who solved this issue feel free to share your workaround.

Thank you!

EDIT: This command launches it:

"C:\sybase_15\Shared\Sybase Central 4.3\win32\scjview.exe"

EDIT: This describes the problem:

                              +-----------------+  
                              |   Stack Trace   |    
                              +-----------------+

Current thread: main    
java.lang.NullPointerException    
  at javax.swing.border.EmptyBorder.(EmptyBorder.java:54)    
  at com.sun.java.swing.plaf.windows.WindowsTableHeaderUI$XPDefaultRenderer.getTableCellRendererComponent(WindowsTableHeaderUI.java:63)    
  at com.sybase.util.SybWindowsTableHeaderUI$XPRendererFix.getTableCellRendererComponent(SybWindowsTableHeaderUI.java)    
  at com.sybase.central.viewer.DetailsList$ImageHeaderRenderer.getTableCellRendererComponent(DetailsList.java:1393)    
  at javax.swing.plaf.basic.BasicTableHeaderUI.getHeaderRenderer(BasicTableHeaderUI.java:394)    
  at javax.swing.plaf.basic.BasicTableHeaderUI.getHeaderHeight(BasicTableHeaderUI.java:428)    
  at javax.swing.plaf.basic.BasicTableHeaderUI.createHeaderSize(BasicTableHeaderUI.java:454)    
  at javax.swing.plaf.basic.BasicTableHeaderUI.getPreferredSize(BasicTableHeaderUI.java:485)    
  at javax.swing.JComponent.getPreferredSize(JComponent.java:1275)    
  at javax.swing.ViewportLayout.preferredLayoutSize(ViewportLayout.java:75)   
  at java.awt.Container.preferredSize(Container.java:1178)    
  at java.awt.Container.getPreferredSize(Container.java:1162)    
  at javax.swing.JComponent.getPreferredSize(JComponent.java:1277)    
  at javax.swing.ScrollPaneLayout.layoutContainer(ScrollPaneLayout.java:702)    
  at java.awt.Container.layout(Container.java:1020)    
  at java.awt.Container.doLayout(Container.java:1010)    
  at java.awt.Container.validateTree(Container.java:1092)    
  at java.awt.Container.validateTree(Container.java:1099)    
  at java.awt.Container.validateTree(Container.java:1099)    
  at java.awt.Container.validateTree(Container.java:1099)    
  at java.awt.Container.validateTree(Container.java:1099)    
  at java.awt.Container.validateTree(Container.java:1099)    
  at java.awt.Container.validateTree(Container.java:1099)    
  at java.awt.Container.validateTree(Container.java:1099)    
  at java.awt.Container.validateTree(Container.java:1099)    
  at java.awt.Container.validate(Container.java:1067)    
  at java.awt.Window.show(Window.java:461)    
  at java.awt.Component.show(Component.java:1133)    
  at java.awt.Component.setVisible(Component.java:1088)    
  at com.sybase.central.viewer.SybaseCentral.run(SybaseCentral.java:147)    
  at com.sybase.central.viewer.SybaseCentral.main(SybaseCentral.java:386)    
  at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)    
  at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)    
  at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)    
  at java.lang.reflect.Method.invoke(Method.java:324)    
  at com.sybase.central.viewer.SCLoader.callMethod(SCLoader.java:207)    
  at com.sybase.central.viewer.SCLoader.main(SCLoader.java:107)

                             +--------------------+    
                             |   Sybase Central   |    
                             +--------------------+

Sybase Central Version: 4.3.0.2414       

*** A java.lang.NullPointerException exception was caught while gathering application information    
  null

                               +---------------+    
                               |   Classpath   |    
                               +---------------+        

C:\sybase_15\Shared\Sybase Central 4.3\sybasecentral.jar    
    Timestamp=2005-08-08 21:17:29.0    
    Length=603123

C:\sybase_15\Shared\java\jsyblib142.jar    
    Timestamp=2005-08-08 21:17:28.0    
    Length=264811       

C:\sybase_15\Shared\java\HelpManager11.jar    
    Timestamp=2005-08-08 21:17:28.0    
    Length=56338        

C:\sybase_15\Shared\java\SCEditor142.jar    
    Timestamp=2005-08-08 21:17:28.0    
    Length=345060

C:\sybase_15\Shared\Sun\javahelp-1_1\jh.jar    
    Timestamp=2005-08-08 21:17:28.0    
    Length=347246

C:\sybase_15\Shared\Sybase Central 4.3\jcchart400K.jar    
    Timestamp=2005-08-08 21:17:29.0    
    Length=1064214



                                +-------------+    
                                |   Java VM   |    
                                +-------------+        

Total memory: 2994176    
Free memory: 739232    
System properties:

    asa.location=C:\SYBASE~1\Shared\SYBASE~1.3\    
    awt.toolkit=sun.awt.windows.WToolkit    
    file.encoding=Cp1252    
    file.encoding.pkg=sun.io    
    file.separator=\    
    java.awt.graphicsenv=sun.awt.Win32GraphicsEnvironment

    java.awt.printerjob=sun.awt.windows.WPrinterJob
    java.class.path=C:\SYBASE~1\Shared\SYBASE~1.3\SYBASE~1.JAR;
    C:\SYBASE~1\Shared\java\JSYBLI~1.JAR;C:\SYBASE~1\Shared\java\HELPMA~1.JAR;
    C:\SYBASE~1\Shared\java\SCEDIT~1.JAR;
    C:\SYBASE~1\Shared\sun\JAVAHE~1\jh.jar;
    C:\SYBASE~1\Shared\SYBASE~1.3\JCCHAR~1.JAR;

    java.class.version=48.0    
    java.endorsed.dirs=C:\sybase_15\Shared\sun\jre142\lib\endorsed    
    java.ext.dirs=C:\sybase_15\Shared\sun\jre142\lib\ext    
    java.home=C:\sybase_15\Shared\sun\jre142

    [CLIPPED]
share|improve this question

migrated from stackoverflow.com Feb 10 '10 at 3:56

This question came from our site for professional and enthusiast programmers.

    
By the way, I found this: groups.google.com/group/sybase.public.sqlanywhere.general/… –  Hamish Grubijan Feb 9 '10 at 14:18
    
Do not want to depend on visual Styles, however. –  Hamish Grubijan Feb 9 '10 at 14:18

3 Answers 3

We use a workaround: Execute with administrative rights and enable compatibilty with "Windows Vista Service Pack 2".

share|improve this answer

You can take a look at program link used to launch Sybase Central. Navigate to location and identify the batch script involving java application (Sybase Central is very old java application). Then go to cmd and use environment settings from script as example and launch javaw or java command to see what exactly fails.

The issue should not be Sybase specific, it most likely java 1.4 issue on Winx64 platform. It should be resolvable with googling the error messages you see in your cmd session.

share|improve this answer
    
Not a bad idea ... for a start. –  Hamish Grubijan Feb 9 '10 at 4:24
    
On win32 the issues were mostly with limited JVM memory, which was fixed with -Xmx1024m key. On win x64 it can be something like memory size confusion, when old 1.4 JVM sees "too few memory" from OS, for example OS reports "negative" number of available bytes etc. To fix this you can try -d64 key. –  RocketSurgeon Feb 9 '10 at 4:29
    
The bug is confirmed by sun. It might have a workaround involving changing your windows Theme. bugs.sun.com/bugdatabase/view_bug.do?bug_id=6428968 Also you can take a look at scjview.bat and uncomment some of SC_LAF settings. I expect that it will either fix it or cause different error –  user34369 Feb 10 '10 at 4:06

You can change the theme as previously suggested (Windows classic seems to work for me) but it's a bit of a pain changing theme every time you want to run Sybase Central, or you can use W2K compatibility mode. I've seen some recommendations about changing the Java version by editing the scjview.bat file but my installation doesn't have that file just the scjview.exe

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.