Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

We have a big problem that's just started happening. One of our network apps (may it rot in hell) requires a mapped network drive to function. Therefore, we map a drive to the network share in question for the users. This usually shows up of course in Explorer as:

Sharename on 'Servername' (Q:)

Problem is, it now shows up as

Disconnected Network Drive (Q:)

And I can't remove it in any way

  • Right-click and select disconnect: "The network connection could not be found"
  • CMD: net use q: /delete - "The network connection could not be found."
  • CMD: net use \servername\sharename /delete - "The network connection could not be found."
  • CMD: net use Q: \servername\sharename - "The device is already in use"
  • Delete the user profile - no change
  • Log in as new, never-logged-in-before user - same problem
  • REG: delete HKCU\Software\Microsoft\Windows\CurrentVersion\Explorer\MountPoints2##servername#sharename - no change

Other items of note:

  • Client machine is Windows Server 2003 R2 x86
  • Server is Windows Server 2003 x86
share|improve this question

closed as too broad by Tom O'Connor May 23 '14 at 12:59

There are either too many possible answers, or good answers would be too long for this format. Please add details to narrow the answer set or to isolate an issue that can be answered in a few paragraphs.If this question can be reworded to fit the rules in the help center, please edit the question.

Are your event logs showing any interesting or related entries? – RobW Feb 19 '10 at 15:19
Do you have a shortcut on the Desktop to that Q: ? If yes, try to delete it. And use UNC paths. – user220971 May 23 '14 at 12:33
@comarc This question is over 4 years old and already solved. Please read through the tour you skipped. – Chris S May 23 '14 at 13:25
up vote 0 down vote accepted

Hmm, okay. I think this might have been a vendor problem!

In case it should assist anyone else (I've seen this issue a few times on Google with various responses), I disabled all the new services installed by the vendor, and after a reboot all drives were fine. It seems one of their services was mapping a drive in (.Net) code, and somehow blocking the network from then on.

share|improve this answer
Out of curiosity, what was the vendor of the problematic service? What kinds of things was it doing? – Henry Jackson Feb 28 '14 at 19:13

I've had quite a few problems with mapped network drives disappearing over night and other issues. One thing I started doing was not using mapped network drives but referring to network paths using UNC notation e.g. \\sharename\path\file.ext

Another issue I had was being told I was connected to a share when it wasn't listed from Windows Explorer. I had to use the NET USE command from the command-line to list, then delete, the offending connection.

share|improve this answer
Thanks for your thoughts. Unfortunately, as I mentioned in the OP, "don't use it" isn't an option (or a particularly useful one) and I've also tried the NET USE process already, as mentioned. – Cylindric Feb 11 '10 at 11:26

I have had the same problem as the OP that persisted with multiple users on the same workstation running Windows XP sp3. I did some poking around in the registry and found this: HKEY_USERS\.DEFAULT\Software\Microsoft\Windows\CurrentVersion\Explorer\PostBootReminders\Microsoft.NetDriveReconnectFailed.

This folder contained the following key/value pairs:

"Title"="Could not reconnect all network drives"
"Text"="Click here to open My Computer and see the status of your network drives."

Of course, this is the text that appears in the information bubble when mapped drives can't reconnect.

When I deleted the Microsoft.NetDriveReconnectFailed folder and its keys from the registry (of course I exported them to a .reg file first), and rebooted the computer, the problem went away. Every user was able to map drives normally, and login scripts worked correctly.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.