Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I just installed SQL Server 2008 Express on my windows 7 machine. I previously had 2005 on here and used it just fine with the old SQL Server Management Studio Express. I was able to connect with no problems to my PC-NAME\SQLEXPRESS instance.

I uninstalled 2005 and SQL Server Management Studio Express. I then installed SQL Server 2008 Express on my machine and elected to have it install SQL Server Management Studio.

Now, when I try to connect to PC-NAME\SQLEXPRESS (with Windows Authentication, like I always did), I get the following message:

Cannot connect to PC-NAME\SQLEXPRESS. A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: SQL Network Interfaces, error: 26 - Error Locating Server/Instance Specified) (Microsoft SQL Server, Error: -1) For help, click: http://go.microsoft.com/fwlink?ProdName=Microsoft+SQL+Server&EvtSrc=MSSQLServer&EvtID=-1&LinkId=20476

When I went to the help link it mentions, the help page suggests the following:

* Make sure that the SQL Server Browser service is started on the server.
* Use the SQL Server Surface Area Configuration tool to enable SQL Server to accept remote connections. For more information about the SQL Server Surface Area Configuration Tool, see Surface Area Configuration for Services and Connections.

I did try starting the SQL Server Browser, but don't see that the Surface Area Configuration is installed with this express version.

I had seen another user with an almost exact same issue that was missing the database engine on install. If that were the case how could i test for that and where would i go to download that install.

Thanks in advance, Billy

share|improve this question

migrated from stackoverflow.com Feb 11 '10 at 3:01

This question came from our site for professional and enthusiast programmers.

    
You can check in you services if SQL Express is running. If the engine did not install you would not have a service for SQL Express –  sadboy Feb 11 '10 at 2:35

2 Answers 2

Check if your SQL Server Express service is running and start it if necessary. Then try to connect to server .\SQLEXPRESS with Windows Authentication.

share|improve this answer
    
I've been trying to figure out this same problem for a couple of weeks. Turns out I was just missing the .\ infront of the server name. D'OH! –  Chad Jul 24 '10 at 14:04

I would simply try "Browse for more..." option in the Server Name of connection dialog. Then check under Local Servers -> Database Engine.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.