Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a problem on my new 2008 R2 64-bit server.

Essentially the server sometimes refuses to access shares on other server.

in the format \\servernam\sharename

sometime it works and then for a few hours it doesn't and then at randon it comes back online. This is a local AD network and have even put in a new gigabit switch between all server. All the old 2003 servers work fine so I know DNS and WINS is all ok.

I get error 1006 in eventlog saying that my R2 server can't contact the domain controller when it clearly can.

Just to add to the config, it is running on a Dell PowerEdge R410, Vmware Esxi 4.0 and R2 is configured as a terminal server.

I can always view shares with FQDN

This morning net view \\ did not work but net view \\ did.

Very random and very frustrating.

any ideas?

thanks

share|improve this question
    
so when you say other servers are they not being hosted on the esxi hosts, I'd assume so since you mentioned adding a new gig switch. Are there any other guests on the esxi server, what about esxi network config how are the vswitches configured see any network events in vcenter? –  tony roth Jun 2 '10 at 5:16

3 Answers 3

Check to be sure system clocks are in sync. Kerberos can cause some flaky issues like this when clocks are > 5 minutes off.

share|improve this answer
    
clock drift on virtual servers can be significant even if you use ntp/nntp –  pplrppl Jun 10 '10 at 21:30

Is the other server running Windows 2003 or earlier version?

Sharing related issues in that scenario (2008 + Xp/2000+ mixed environment) are quite common unfortunately.

One common solution is to check if NetBios over TCP/IP is enabled on all machines in the subnet.

As an alternative you could map the network shares by their ip addresses instead of netbios names.

Anyway, Microsoft TechNet provide some good documentation about this problem.

M

share|improve this answer
    
Lowest server is 2003 SP2. I can map via IP or name and sometimes IP doesn't work and hostname does. Very odd. Microsoft have been logged in and as of yet no fix. –  Rob Feb 11 '10 at 14:45

A) firewall ? B) or try this

1) Set the registry values concerning security (in lanmanworkstation & lanmanserver) to 0 (Source and Target server)

2) HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\lanmanworkstation\parameters

3) enablesecuritysignature [REG_DWORD] = 0x0

4) Reboot

5) Go to Target server type gpedit.msc  Computer Configuration\Window Settings\Security Settings\Local Policies\ Security Options and disable following features

6) Microsoft network client: Digitally sign communications (always)  disable

7) Microsoft network server: Digitally sign communication (if client agree)  disable

8) Network security : LAN Manager authentication level  Send LM&NTLM – Use NTLMv2 session security if negotiated

9) Domain Member : Digital encrypt or sign secure channel data  disable

10) Domain Member: Require strong (Window 2000 or later) session key  diable

11) Reboot

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.