Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

How can you disable TeamViewer from using/reserving port 80? I am certain in the previous version <v4.1.6 there used to be a radio button option in "options" which disabled it from needing it, but now I cannot find it.

Is port 80 serisouly required by this remote desktop app? It is conflicting with IIS on our development server and becoming a real pain.

Thanks all.

share|improve this question
add comment

8 Answers

up vote 17 down vote accepted

Did you enable the Direct-In Modus? You can disable it in

   Options > Advanced > Network > TeamViewer DirectIn check

From the manual, page 59 (PDF):

Check Opens a dialog where the availability of TeamViewer is checked. The DirectIn Ports 80 and 5938 do not have to be opened , however, TeamViewer can use these ports - if available - for establishing faster connections.

share|improve this answer
    
Thanks. I looked at that checkbox, paused on it, then moved on. If only I clicked on options for it I would have noticed it wanted to use port 80! :) Thanks. –  GONeale May 23 '09 at 0:50
    
Page 59 of the PDF seems incorrect; I found the info about DirectIn options on page 78 of 81 (the PDF itself regards it as page 82). –  JYelton Aug 27 '10 at 17:40
add comment
Options > Advanced > Show Advanced Options > Don't use incoming ports 80 and 443
share|improve this answer
add comment
  1. Open port 5938 (TCP) on your firewall.
  2. Change the following registry keys.

    • [HKEY_LOCAL_MACHINE\SOFTWARE\ TeamViewer\Version4] Key ’GatewayAllowed’ set to 0 * [HKEY_LOCAL_MACHINE\SOFTWARE\TeamViewer\Version4] Key ’ListenHttp’ set to 0
share|improve this answer
add comment

On the new teamviewer you go to advanced settings and then Don't use port 80

share|improve this answer
add comment

The DirectIn check merely checks whether port 80 is forwarded through your router, it does not stop hijacking port 80. There is a registry change that you can make (two values need to be changes, one obvious, one non). I don't have the details with me, but if you telephone TV tech support, ignore their "this is just how it works" and insist on talking to a tech, you may be able to get it. I'll post the changes as soon as I get to my own computer.

share|improve this answer
add comment

If you are using Windows 7 x64, you will find that the registry keys are in a different location. I have searched the registry and cannot find anything along the lines of 'GatewayAllowed'. The other key is as follows:

HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\TeamViewer\Version6\ListenHttp

share|improve this answer
add comment

Starting the Apache server before teamviewer seems to solve this problem.

share|improve this answer
add comment

You can disable this behavior in TeamViewer version 5.1 or newer.

Open TeamViewer options under Extras > Options > Advanced. Enable the option "Don't use incoming port 80 (recommended for web servers only)" so that TeamViewer won’t try to take the Port again.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.