Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've recently upgraded my client PC to Windows 7, and ever since I can't get local resource sharing for remote desktop to work. I'm connecting to a 2003 server which isn't is my current domain. All my optical and virtual drives are being shared, but the C drive stays hidden. I checked the options, and do indicate that I want to share my C drive.

Is there any permission I should change for this to work?

The server is configured correctly because when connecting from an XP client this problem doesn't occur.

I've tried accessing the share directly by opening the \\tsclient\c path, but this doesn't work neither. \\tsclient only shows the other drives.

Also copy 'n paste doesn't seem to work neither(tried restarting rdpclip to no avail), getting Cannot copy file File.dat, the device is not connected.

share|improve this question

5 Answers 5

It's a known issue with a hot-fix available and a workaround.

The workaround is "Enable Smart Card redirection".

See http://support.microsoft.com/?kbid=940458

share|improve this answer

That's a nasty one. I have a few ideas.

  • Are you checking the top-level "drives" option or just specific drives? That can make a difference sometimes.
  • There's a possibly useful thread on the technet forums regarding this exact issue, but no response as to whether or not the answer actually helped.
  • It could also be the version of Remote Desktop Client. I think they tweaked the protocol for Vista -> Vista connections, and may have done so again with Win7. Although all versions appear to be forwards and backwards compatible this might be one of those weird side effects.
share|improve this answer

Since I can't post multiple-link answers without more rep, here's another option:

  • The accepted answer on this technet thread talks about security policies affecting RDC connections. It was a question about colour settings, but maybe there are drive options in there too (I don't have a Win7 box handy right now to check). I could copy/paste the instructions but they're complicated as usual :)
share|improve this answer

If they're on different domains, are you sure you are authenticated on the remote domain? Try setting up a local account on the box to log in with.

share|improve this answer

I googled for Admin shares and Windows 7 and it does't look pretty. Have a look at the following blog http://blog.hansmelis.be/2009/09/06/administrative-shares-in-windows-7/

share|improve this answer
    
But is the \\tsclient\c the same as the c$ share? If so, why does the RD client in Windows 7 still include the options for sharing the drives? –  Robert Massa Feb 12 '10 at 16:01
    
OK, lets ask a few questions: Are the permissions correctly set for your user (domain/local user)? \\tsclient is your local client (win7) or your server? If local, check everything from the blog I mentioned. Win7 might be intelligent? I assume you specifically created the share \\tsclient\c, is this the case? Us there any firewall in place? –  Peter Schuetze Feb 12 '10 at 17:16
    
I didn't create any share myself. The Remote Desktop client does this by itself, if you turn on the option to share local devices. \\tsclient is the place on the server where these shares are available. I think admin shares are different from the shares Remote Desktop creates. –  Robert Massa Feb 15 '10 at 7:53
    
I would have tried what many people tried in regards with the Admin Shares. Microsoft definitely messed around with the default network setting. So try everything and single out the settings that help you. I can't help you more since I have no Win7 to test. You might even try to post on superuser. Maybe someone experienced something similar. –  Peter Schuetze Feb 15 '10 at 16:09

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.