Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am in the process of trying to configure SQL Server 2008 to accept remote connections. I have been through all the documentation I can find and yet when I attempt to connect through management studio I get an error stating that the server could not be found.

Interestingly I can connect through telnet to the remote server via the port that sql server is listening on. In the SQL Server logs I can see the connection attempt. So SQL Server is up and running and listening on the correct port - no firewall blocking it.

It would appear that by default SQL Server is listening on port 50314 but management studio attempts to connect on port 1433. Weird.

Server Management Studio = no dice.

Anyone got any ideas? Server is set to allow remote connections - TCP IP is enabled, firewall is off.

Thanks

share|improve this question
    
You can see the Management Studio connection attempt in the logs, or is that just the telnet connection attempts? –  blueberryfields Feb 12 '10 at 18:09
    
just the telnet connection attempts. ill add some more detail to the question –  WarpKid Feb 12 '10 at 18:10

2 Answers 2

up vote 0 down vote accepted

If SQL is not listening on port 1433 then you either have to either

  • Specify the port in your SSMS connection (your servername and port number separated by a comma)

    "Server Name: mysqlserver,50314"

or

share|improve this answer

There is another port, 1434, which is listened in UDP by the SQL Service Browser service. When a client attempts to connect to a non-default SQL instance it will first ask the SQL Broswer service for instance information and the SQL Service browser will respond with the (dynamic) port the instance is actually listenning on. Then the client opens a TCP connection with the actual instance.

So now is clear that you need to poke a hole in the firewall for the SQL Server Browser service (1434 UDP) so it can listen, and you also need to start the service and mark it as automatic start up (by default is installed as disabled).

share|improve this answer
    
We disabled the firewall and ensured that the Server Browser was running but still could not connect. Thanks for info tho, I would flag your answer as useful if I had the rep! –  WarpKid Feb 12 '10 at 18:30

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.