Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We just setup some new Windows 2008 R2 servers and we are unable to Remote Desktop into them from our Windows 7 desktops. Remote desktop connects, but after we provide credentials we get:

The connection cannot be completed because the remote computer that was reached is not the one you specified. This could be caused by an outdated entry in the DNS cache. Try using the IP address of the computer instead of the name.

If we connect from Windows 7 to a machine not running Windows 2008 R2, or from a machine not running Windows 7 to the Windows 2008 R2 server, it works fine. Likewise if we connect to the Windows 2008 R2 server from Windows 7 via the IP address then it works fine (although that causes other problems later).

I've only found one other mention of someone having this problem, so I don't think it is just our network.

Any suggestions on how to connect from Windows 7 to Windows 2008 R2 via DNS? Both are 64-bit.

Update: Turns out it does not need to be R2 to get the error. We have another server that is Windows 2008 R1 64-bit that also fails.

share|improve this question
    
Got one R2 server experiencing this after a reload as well. It has its hostname A record and reverse lookup correctly defined and there's a CNAME pointing to the FQDN that was previously used to address it. Now this throws this error and server, client and all DCs are in sync... getting annoying as there was no problem with the previous RC R2 install on that particular machine - and it has retained the same IP address... –  Oskar Duveborn Mar 3 '10 at 11:37
add comment

6 Answers 6

Have you tried flushing the dns cache?

ipconfig /flushdns

Sounds like the problem lies somewhere in the DNS.

  1. Check normal name lookup through DNS.
  2. Check reverse DNS lookup on the IP address of the Windows 2008 R2 machine.
  3. Examine the DNS records created for the servers / windows 7 machines on the DNS server.
  4. Try disabling IP6 on both machines.

Reference this

Time and again we see the IPv6 stack operating under the hood, having a silent affect on applications. One area we have seen this is in DNS calls for application servers. Depending on the application and specific stack in use, the client may make DNS calls over IPv4 requesting the IPv6 address of application servers

share|improve this answer
add comment
up vote 4 down vote accepted

It appears this was at least partially related to the clock on the domain controller being off. Once the time was corrected then it worked.

share|improve this answer
    
gotta love detailed error messages... –  Hubert Kario Nov 8 '12 at 21:22
add comment

Yes, make sure the time on the target server is accurate. It has to be within 5 minutes of the DC usually or servers and workstations start to act funny, though it should be exact. I corrected the time on my newly reformatted target server (2008 not R2) and immediately connected afterwards from my Win7 PC.

share|improve this answer
add comment

This can happen if you use a certificate and the names don't match.

share|improve this answer
    
You have not provided any substance to your answer. To answer you need to provide some workings to how to diagnose the issue and then provide a suggestions on how to resolve it. To improve the answer further you can provide references to support your workings. –  Bernie White Nov 20 '12 at 9:39
add comment

The solution i had to fix this problem was..make sure you dont have the connection broker role installed on both servers. Even if you do, make sure that load balancing is only checking and working on ONE server. (Which is the connection broker)

share|improve this answer
    
The answer would be improved by providing a reference to an official KB or further explaining why installation the connection broker on two servers causes the problem. –  Bernie White Nov 5 '12 at 9:07
add comment

http://public.madeinengland.co.nz/the-connection-cannot-be-completed-because-the-remote-computer-that-was-reached-is-not-the-one-you-specified/

This gives a bunch of things that tell you how to get around this issue

share|improve this answer
1  
Welcome to Server Fault! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. –  Scott Pack Nov 8 '12 at 21:28
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.