Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

The normal location for the download of PowerShell v2.0 is Windows Management Framework (Windows PowerShell 2.0, WinRM 2.0, and BITS 4.0) (KB 968929).

You'll notice that there isn't a listing for Windows XP x64, and the x86 version will not work. I can't find any information online about this specific problem, but maybe I'm not looking in the right place.

Is it possible to run PowerShell 2.0 on Windows XP 64-bit?

share|improve this question

1 Answer 1

up vote 2 down vote accepted

This guy says to download the Win2k3 X64 from that page and try it. I don't have XP 64 so can't test it, but his reasoning is ... reasonable.

share|improve this answer
1  
After doing this again, I realized I had actually tried that before. It doesn't fail on the install and by all indications it would lead you to believe it works. But if you actually run powershell it shows up as v1.0. At least for me it does. –  jasoncrider Feb 12 '10 at 18:45
    
EDIT: By looking at the registry setting the PowerShellVersion actually does say 2.0. It's still under a folder named v1.0 and running powershell shows that. –  jasoncrider Feb 12 '10 at 18:53
    
Yup, within PowerShell run $psversiontable. That doesn't exist in v1. The "v1.0" folder is also used in PowerShell v2. "v1.0" is here to say until PowerShell is built on the next version of the .NET CLR (blogs.msdn.com/powershell/archive/2007/11/02/…). –  Marco Shaw Feb 12 '10 at 19:11
    
For determining the version of PowerShell: see Stack Overflow question How to determine what version of PowerShell is installed?. –  Peter Mortensen Sep 1 '13 at 19:17

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.